Setting advanced DHCP settings causes the webgui to 403



  • Just posting this to make sure it is a bug before posting it to the bug report section. Setting advanced protocol timing to the Freebsd defaults caused a 403 ngnix error for me, and it caused SSH to kill the session ever ~15 seconds.


  • Netgate

    What, exactly, are you doing when this happens.

    Please detail all steps, what browser, what browser version.



  • Google Chrome, Version 70.0.3538.77 (Official Build) (64-bit). Windows 10 64 bit.

    I was adjusting WAN DHCP settings. I ticked Advanced Configuration, then ticked FreeBSD defaults under presets. I'm using the latest version of Pfsense, 2.4.4 RELEASE. It's a fresh install too, I just reinstalled because I lost access to SSH. I can post my XML too, in case you need it.

    Packages:
    acme 0.3.2_4
    haproxy 0.59_14
    iperf 2.0.5.5_3
    nut 2.7.4_7
    openvpn-client-export 1.4.17_2
    pfBlockerNG 2.1.4_13
    Service_Watchdog 1.8.6
    Status_Traffic_Totals 1.2.4
    suricata 4.0.13_9

    Haproxy is disabled from its setup page.


  • Netgate

    Hmm. Worked here. Don't have the same package set but worked here.

    WAN events are expensive. Sometimes you have to tell the browser to reconnect when you mess about with interfaces like that.



  • SSHing in and restarting, resetting the webgui, and resetting php did nothing. Only a rollback to before the changes were made fixes anything.



  • For clarification it was a 502 Bad Gateway error, not a 403.