Upgrade failed; SG-2220 won't boot from USB

  • I just attempted to upgrade my Netgate SG-2220 from 2.4.2 to 2.4.4 and the upgrade appears to have failed.
    I'm not sure what went wrong, but it seems like a file system issue; the firewall tries to repair the filesystem, can't find a kernel and shows dozens of php related errors during the boot process.

    This didn't come as a huge surprise so I had a config backup and a 2.4.4 USB stick prepared (pfSense-netgate-memstick-ADI-2.4.4-RELEASE-amd64.img) but the problem is that I cannot get this machine to boot from USB at all.

    I've tried four different USB sticks, each a different brand (two 2.0, two 3.0), rufus on windows, etcher on mac, cleared the sticks before use.
    One of them was known to be working because I used it to reinstall a SG-4860 at a different location a few days ago and didn't touch the stick since.

    The USB sticks don't show up in the F12 boot menu and there's no trace of them in dmesg. The SG-2220 just tries to boot from the broken internal installation every time. The sticks light up when booting, so I know the USB port is at least powered up.

    Any ideas would be very welcome because the location is without internet right now. If nothing else that'll teach me to attempt booting from USB before upgrading... ☹

  • Rebel Alliance Developer Netgate

    Drop the support team a message at https://go.netgate.com and they can help get this sorted.

    Though it does sound like you've tried most of the usual combinations of factors there. Did you try booting in the upper or lower USB port on that 2220?

    If it worked on the 4860 then the image you downloaded must be good, so at least there shouldn't be any question about the integrity of the installer

  • Thanks for the response. The device is older (many years) and I don't have a support package, so I haven't contacted support. My 2220 only seems to have one USB-A slot and the micro-USB for the console.

    I'm downloading a 2.3.5 to try that and am scrambling to find any simple but working router, once things are temporarily working again I'll take the time to contact support.

    This is how one of the sticks looks from a freebsd vm. I tried to follow the commands in the wiki but they didn't seem to work, maybe because it is a vm.

    alt text

  • Rebel Alliance Developer Netgate

    You shouldn't need to make any manual adjustments to the memstick for the 2220, the ADI memstick should work as-is.

    Even if it's out of warranty the support team can still assist with getting an OS back on there

  • Ok, I put a different temporary router in place and sent a ticket to support. I hope it is not a hardware issue.

  • This post is deleted!

  • Support was exceptionally helpful and helped me through a few troubleshooting steps. Unfortunately it appears to be an out-of-warranty hardware issue.
    The USB port is not working and the filesystem on the eMMC flash can't be repaired with fsck, so either both failed, the USB bus is defective or there's something else going on.

    I have shipped it off to my vendor for examination hoping that it can be repaired at cost.
    Funnily just had a SG-4860 from the same order (Oct 2015) fail last week. Luck is not on my side but at least I had ordered an identical unit just after the EOS announcement this spring and only needed to restore from backup.

  • Last update to this — the vendor confirmed that USB is no longer working but was able to repair the appliance by installing a small SSD and put the recovery image on the eMMC just in case.

    This turned out to be more cost effective than buying a new unit and should buy me some time until new hardware is released and the whole microchip/licensing future becomes clearer.

Log in to reply