PfSense boot skipping optical drive



  • Earlier today I installed PfSense fresh but discovered I had installed 2.3.1 32 bit by accident. I used a CD I had made over a year ago, and the installation went fine, just the wrong version. The machine I'm using is an old Athlon II dual core that I've been running PfSense on for over 2 years. The boot order in BIOS has always been set to boot from optical drive first (TSST DVD writer SH-202) which has never given me problems. Now no matter what I try the machine will not boot from a DVD or CD at all, it will sit there acting like it's reading from optical disk then go ahead and boot into PfSense 2.3.x. I've tried a couple different Ubuntu live discs, 2.4.2 X64 PfSense discs that I've used before to install PfSense with no issues. Not even a Windows disc will boot. I remember when I upgraded from 2.3.x to 2.4.x (both X64 versions) this was not an issue. What am I missing to either get the machine to boot from the optical drive or format the hard drive? Is there something about 32 bit PFSense that is somehow able to block a 64bit CD or DVD from booting?
    I tried 2 other DVD drives just in case but got the same result.



  • an operating system doesn't have the ability to block the BIOS from booting from CD ....

    more then likely the cd-drive is having issues or there is an issue with the boot-order



  • @heper as I stated the optical drive is and always has been first in the boot order, and I tried other opticals that work fine. The BIOS on that board has never given me trouble.



  • Everything works until it breaks. OS can NOT affect the hardware like that, with rare exceptions. Your problem is either with the drive, the cable, the cable connection, or the media.


  • Netgate Administrator

    Yup, nothing in pfSense (or any OS) could do that.

    Since you've tried multiple optical drives I'd swap out the cable if you haven't. Then I'd reset the CMOS in case it's been corrupted somehow.

    Then I'd boot from USB instead. 😉 (Though I assume maybe you cannot on that box).

    Steve



  • Thanks for the help but I decided to just stick to the working installation. I thought it would be simple to install a fresh PfSense to a different hard drive compared to jumping through extra hoops to clone it, not expecting this crazy problem. At some point later I'll clear CMOS and try again but the current drive is fine so it isn't a major priority.