Dynamic DNS not working in 2.4.4 - SSL error



  • I'm trying to configure DynDNS (Dynamic) service. I'm able to login to Dyn website and perform updates manually. However, when I put the correct info into Services > Dynamic DNS and force and update, it comes back with IP address in red in cached column 0.0.0.0. I see the following entry in System Logs:

    /services_dyndns_edit.php: Curl error occurred: SSL: no alternative certificate subject name matches target host name 'members.dyndns.org'.


  • Netgate

    There are three different DynDNS selections. You have to be using the correct one and have it properly-configured for the service you subscribe to with them.



  • Thanks for your reply. I'm subscribed to DynDNS Pro and would like to have pfsense update my Dyn host record regulary since my ISP does assign me a dynamic IP address. The three options I have in pfsense are DynDNS dynamic, custom, and static. I currently have it set to dynamic, but I just tried using the other 2 options and it still shows the same error in system logs about SSL certificate and 0.0.0.0 in red under services > Dynamic DNS.

    I'm not sure what else to check. Let me know how I can gather more info for troubleshooting.

    Brian



  • Wild guess: You are running pfBlockerNG and one of your lists is blacklisting dyndns.org. Go to Diagnostics -> DNS Lookup and see where members.dyndns.org resolves to. If that isn't the problem open https://members.dyndns.org in your browser and check it's certificate, they may have messed up something on their end.

    If you want more accurate help you need to provide details about your setup.