Pfsense full install on Alix



  • Hello,

    This is driving me crazy. I tried to install PFSense (Full install) via LiveCD (tried 1.2.2 and 1.2.3) according to instructions on the page. Used Virtual Box. I run on a 4 GB Hitachi Microdrive.

    I have been able to install on a number of devices. However a new install constantly fails after Formatting / Partitioning the Microdrive with the error:

    Execution of the command
    /sbin/newfs  /dev/da0s1a

    Failed with a return code of 38

    the log file says:
    cg 0: bad magic number

    I have tried now 4 different Microdrives (any one interested ;-) But also have this error.

    Thanks in advance
    Hans



  • Hello,

    I had the same problem, altough I was using 1 GB CF card and newest PfSense 2.0-ALPHA. First I used some external USB memory card reader (tried on two machines) and also with VirtualBox, but it gave me the same error than yours. Then I booted my desktop computer with the LiveCD and used the memory card reader in my desktop computer (maybe Sony internal usb) and that worked better. So maybe you can try with some other reader.

    So my Alix 2D3 is now running full version of PfSense 2.0-ALPHA (19.3.2009 20:00) and this far, no problems. I'm going to make some firewall rules and OpenVPN configurations tomorrow, lets see what happens…

    --
    Janne



  • I have the exact same problem but with the exact setup, i was able to install PFSense 1.2. With 1.2.3, something has changed and it no longer works. If someone can provide a full install image, 1GB at least so I can image my microdrive with 1.2.3 full install (prefer latest snapshot).

    Thanks!



  • Well I have it working, but I bought a seperate external USB CD-Rom. It has to do with the USB CF reader. Something is no longer working.

    So full install from CD on USB CD-Rom drive and no longer any problem.



  • hansru, that only works for D series.
    I don't think ALIX C series support boot from a usb cdrom.


Log in to reply