only some nics reporting as up but all are detected



  • I've got an old uSVR from Compulab I'm trying to setup with pfsense. This unit has the optional quad port nic in addition to the two built-in nics for a total of 6. My issue is I can only get 2 of the 6 nics to be reported as up even though pfsense sees all 6 nics.

    When I remove the quad port nic, the 2 built-in nics work fine.

    When I install the quad port nic, only 1 of the 2 built-in nics work and only 1 of the 4 ports on the quad port work.

    At the console I can see all 6 nics (all reported as the same Intel branded nic) but in the assign interface option, only 2 of 6 ever report as up. It's been a while since i've used this but i think i did manage to get all nics to work within windows back in time.

    Is there a log I can check to see why things aren't working? I'm at a loss since the nics are detected and 1 of 2 lights on the physical port of the PC lights up (I guess the orange link light, there's no blinking green light like the working ports). From my test above i can confirm that at least 3 ports work fine, just not all at once.

    thanks


  • Netgate Administrator

    If they are all the same type then connecting the 4 port NIC could well re-order the interfaces if they are detected differently.
    It sounds like in both cases you have two NICs that function, just different NICs?

    If you go to Interfaces > Assignment are all 6 NICs available to assign?
    If not then check the boot log for driver attachment errors.

    If you only have 2 interfaces assigned and enabled then only 2 will work.

    Steve



  • Thanks for the hint. I think I got the issue resolved. I was trying to use the console to figure out which nic was active so I can assign my lan/wan to the nics i wanted. I was doing this by using option 1 (assign interfaces) and seeing which nic was showing as up in order to assign things before logging in for the first time.

    After going into Interfaces > assignments and adding the extra 4 nics and then clicking on each one and selecting enable, pfsense now seems to be detecting the interfaces as up.