Port Forward Issues with a custom ARK Server



  • Hello I've been trying the whole day to fix this port forwarding issues.

    I am currently using pfSense 2.4.4-Community.

    The issue im facing is that people outside my lan cant see my Ark Server.

    I've already open the ports and they seem to be working fine. Because I have manually test each port with tshock (terraria server) which apparently is p2p.
    What is odd is that all the ports works fine, but when I do open the ark server it just wont show up (it does connect on lan though).





  • Darn it! Now I feel like a retard.
    Actually the link would be: https://www.netgate.com/docs/pfsense/nat/accessing-port-forwards-from-local-networks.html
    Anyways, I've seen many people with this issues in other forums so, here is some usefull info (quoting):

    • In order to access ports forwarded on the WAN interface from internal networks, NAT reflection must be enabled.

    • In order to do this, navigate to System > Advanced, Firewall/NAT tab. On that page, select Pure NAT for NAT Reflection mode for port forwards, check Enable NAT Reflection for 1:1 NAT, and check Enable automatic outbound NAT for Reflection. Click Save.

    This is what newbies on this (like myself) would not know (this is actually the fix): NAT+Proxy mode for port forward reflection sets up a proxy daemon and rules to receive and reflect only TCP connections. This method the only available means of reflection in earlier versions of pfSense. It can work in certain rare circumstances where Pure NAT mode does not. This will only work with single port forwards or ranges of less than 500 ports. It does not work with UDP or other protocols.

    And this fixed my ARK Server issues with pfSense. Thank you.



  • Something is not quit right here. You said the symptom of the problem was that you could access your local game server on LAN, but your users on WAN could not. NAT reflection will not address that issue. I suspect that there was a problem with the NAT you created and you somehow fixed it but thought it had to do with NAT reflection.