Issue on fresh install



  • I have done a new install on a new router we need, Install went ok,
    I am trying to perform initial configuration of the router, and when I attempt to configure the LAN, it wil lnot work and gives an error.
    I am setting Lan address as 192.168.2.1/24
    No IPV6
    enable DHCP

    For the DHCP range, I tried a few different ones but ideally it will be something like 192.168.2.20 through 192.168.2.60 or so.

    Once I hit enter for the end range, it gives this error:
    Fatal Error: Uncaught Error: Cannot use string offsetas an array in /etc/rc.initial.setlanip:417
    And shows a stack trace.
    Am I doing something wrong here? I admit it has been a while since I have done initial setup on pfsense since I have been in a cycle of upgrades on an existing router stock, but it seems like the info I am entering should be right.

    EDIT: Added pic
    0_1542306736395_IMG_20181115_110726(1)(1).jpg



  • Am I doing something wrong here?

    Maybe. Post some screens of your config tat causes the error so others can try to reproduce it. Right now we have no idea what you have done past your brief description.



  • got a pic in OP now (had trouble with getting an appropriately sized image)
    This is in the console, on initial configuration. Seems to happen with both NICS (I tried using the other one as LAN instead, no dice) This is a completely fresh install on a new machine, ZFS install if it matters.



  • Try to deactivate DHCP on initial setup and do the DHCP settings later in the web GUI.



  • The CIDR suffix you added to the start address might have confused it.



  • Not enabling DHCP did it. Not sure why that would even be, but it worked, many thanks