OpenVPN server (Can't have more than one client routing) Netgate sg-2440 (Resolved)



  • Hello,

    I am having an issue where I can have more than one client connected but only the first connected client gets any routed traffic.

    Ie: I connect my personal phone and it's fine, I connect my laptop or work phone and both fail to work. If I disconnect all the devices and reconnect my laptop it works then if I connect my personal phone or work phone they can't get any traffic.

    My initial thought that this was related to 2.4.4 but downgrading to my past version did not fix it.

    I don't use my Vpn heavily unless I am traveling. I last used it in July and it worked flawlessly from my home in the NW all the way to Alabama with all my devices connected pretty much full time for 2 weeks. Since then I only updated from 2.4.3 to 2.4.4.

    I also reinstalled 2.4.3 and restored a backup from when I was out of town and the issue still persists. At the moment I am at a lost and don't know what else is wrong and am about to setup something different for VPN as much as I don't want to because I liked the way it worked with pfsense on it's own. Below are pictures of my OpenVpn setting. Please let me know if you need more information if needed to be confirmed of checked.

    https://127.pictures/64e7.png
    https://127.pictures/a8Q5.png
    https://127.pictures/n3N1.png
    https://127.pictures/D6k4.png

    Thanks



  • Specify "Concurrent connections" in the server settings.



  • yeah :
    0_1542369614935_effe8044-c3f5-49e8-9990-f5a2f3caef3a-image.png



  • I saw this earlier and I did play with this and it did not make any difference, sadly. To my knowledge this was always empty. Currently I set it to 10 again to test, restarted the server and repeated my test and got the same result. Phone 1 connects and works fine, phone 2/Laptop connect, but I can't get any traffic to anything on the internet or even on local, both time out on the 2nd connected device.

    alt text

    Thanks for for the reply.



  • Is your tunnel subnet mask set to allow multiple client IPs?



  • ok. How did you configure the OpenVPN Server on the pfSense ? With the wizzards ?
    Because I've the same configuration, with many differents companies and users and it's working fine


  • Rebel Alliance

    Post your OpenVPN Log.

    -Rico



  • Hello,

    This was originally setup with the wizard, yes.

    Where would I check the multiple IP setting? I don't recall every seeing that option anywhere.

    Here are a few more pictures including one with the log.

    alt text
    alt text

    In this instance, the ios device was connected first and worked and my normal user which was an android phone connected, but could not route any traffic.

    Thanks,



  • I think in this menu "VPN//OpenVPN//Servers//Edit" you can change the subnet's mask

    0_1542620024308_4421caf2-e767-43c0-930a-aad30fc29b6e-image.png



  • Hello,

    Well, tl:dr that fixed it.

    I am not sure what would have changed to cause that to fail randomly between a few months but I am glad and thankful for the tips from every involved to help me fix this.

    Thanks,