zabbix-agent4 not running on 32xxx port needed to connect to docker



  • I tried to install the agent, but on 10050 port the agent runs fine (no server listening). When I change to 32961 the docker local port the agent crashed.

     19073:20181118:091447.686 Starting Zabbix Agent [JANUS]. Zabbix 4.0.0 (revision 85308).
     19073:20181118:091447.686 **** Enabled features ****
     19073:20181118:091447.687 IPv6 support:          YES
     19073:20181118:091447.687 TLS support:           YES
     19073:20181118:091447.687 **************************
     19073:20181118:091447.687 using configuration file: /usr/local/etc/zabbix40/zabbix_agentd.conf
     19073:20181118:091447.687 agent #0 started [main process]
     19189:20181118:091447.687 agent #1 started [collector]
     19231:20181118:091447.687 agent #2 started [listener #1]
     19296:20181118:091447.688 agent #3 started [listener #2]
     19404:20181118:091447.688 agent #4 started [listener #3]
     19296:20181118:091710.149 Got signal [signal:15(SIGTERM),sender_pid:16781,sender_uid:0,reason:65537]. Exiting ...
     19404:20181118:091710.149 Got signal [signal:15(SIGTERM),sender_pid:16781,sender_uid:0,reason:65537]. Exiting ...
     19231:20181118:091710.149 Got signal [signal:15(SIGTERM),sender_pid:16781,sender_uid:0,reason:65537]. Exiting ...
     19073:20181118:091710.149 Got signal [signal:15(SIGTERM),sender_pid:16781,sender_uid:0,reason:65537]. Exiting ...
     19189:20181118:091710.149 Got signal [signal:15(SIGTERM),sender_pid:16781,sender_uid:0,reason:65537]. Exiting ...
     19073:20181118:091710.150 Zabbix Agent stopped. Zabbix 4.0.0 (revision 85308).
    
    

    Any clue ?