SG-2440 future-proof for 2.5?



  • All,

    Sorry if this has already been answered (could not find in search) but I just wanted to confirm that the SG-2440 is indeed AES-NI compatible and will work with pfsense 2.5 when it becomes available.

    Thank you



  • If you log in, the home page under "CPU Type" will show if it has AES-NI.

    That said, some relatively recent Netgate routers like the SG-3100 don't show that but I haven't heard they aren't compatible...?



  • Pretty sure the crypto chip in the sg-3100 will allow it to work with 2.5. Thought I read on here that was one of the reasons they included it, besides the cpu not supporting aes-ni.