Shaw 300 issue with Arris XB6 modem - severe intermittent WAN slowdowns



  • I upgraded from Shaw 150 after several years and got a new Arris XB6 modem. Have been using a home-built PfSense router. Seems like after a month or so my Shaw Internet started having problems - internet traffic would grind to a halt. I checked the router and it did not show any connection issues. The internet does eventually come back full speed but this seems to happen several times a day and makes my system basically unreliable. If I restart everything then it usually comes back to normal. I have replaced modem from Shaw and still the same problem.

    I also have Telus ADSL... when this issue happens with Shaw (when I am around to catch it), I simply unplug the WAN from Shaw Arris XB6 and plug into Telus ADSL modem and internet works perfect without touching anything on the PfSense router at all. At one time I had a PfSense router setup with Shaw and Telus plugged into two different ports. When internet had issue I would go into the web interface of PfSense and change the gateway to Telus port and internet would instantly come back up. This baffles me. Shaw modem works otherwise with different routers in bridge mode and using its own built-in router (in non-bridged mode)

    To make a long story short, I tried several different configurations of PfSense hardware and even a Netgate SG-2220 - all having the same issue where the internet traffic drops after a while.

    Shaw is no help... they don't officially support bridge mode.
    Does anyone else have any issues with PfSense and Arris XB6 modem?

    I am currently running a Cisco RV320 on the Arris XB6 and it works fine for past 2 months but I would rather run PfSense.

    BTW, I was using PfSense 2.4.4 the last time I had tried.


  • Netgate Administrator

    What problems were you actually seeing? Packet loss? Latency?

    Did the pfSense monitoring graphs show the issue in the 'quality' data?

    Does it coincide with increased throughput? Any particular type of data?

    You can run both those WAN in a failover configuration if you want.
    https://www.netgate.com/docs/pfsense/routing/multi-wan.html

    Steve



  • I used exact same pfsense configuration for almost a year on my Shaw 150. I upgraded to Shaw 300 which required a new modem. For the first month or so I did not notice any issues, but then started having problems. Thought it was Shaw and the modem at first. I think maybe a firmware upgrade from Shaw may have caused this problem. I still think it is something Shaw did, but still a bug possibly somewhere in PfSense because other Cisco router is fine.

    Typically problem would be most noticeable if watching Netflix or Youtube. I don't believe watching video caused issue but it was just noticeable because watching video one can see a direct result of any problem. All of a sudden the video would stop. During this time I would connect to the pfsense admin page and everything looked fine - WAN was up. I could also ping the WAN gateway and even other hosts on WAN eg. 8.8.8.8 and other domains like cnn.com etc. IPSEC VPN Tunnels to work still were up but no traffic going through. Often I would be at work and lost ability to RDP into my home servers although the VPN tunnels still showed up and I could ping hosts across tunnel.

    Fail over configuration won't help with this issue because this is problem with pFsense not working with my Shaw 100%. Only reason I have Telus is because I am comparing both for a while to see which one to stick with.

    If I left it for a few minutes traffic would start to flow again - anywhere from a couple min to half hour it would take. Sometimes when it seemed that it was taking longer to come back... I would just swap WANs with my Telus ADSL and internet traffic would instantly be flowing again... I would then revert back to Shaw and network still be down. I would also connect a device like a computer or my iPhone (using lightning to ethernet adapter) direct to Shaw on 2nd WAN IP during this time and was able to use without any slowdowns while my pFsense LAN was not. Restarting pFsense router seem to fix problem temporarily until it happen again. Sometimes hours or nearly a day would go by before I would witness the problem again... frustrating because it is not easily reproducible and many times I thought I had solved it only to be defeated again.

    I went through every option I could think of with no luck - spent many hours/evenings troubleshooting. I even placed a gigabit switch in-between in case there was problem the shaw and pfsense NICs not talking correctly.

    Just wondering if anyone had same Shaw 300 as me with similar problem.

    The only configuration I did not try was a double-NAT off the modem to rule out bridge mode issue with Shaw. I didn't do this because I require VPN tunnels to be working for my job.

    This weekend I will throw a pfsense on WAN of Arris modem so I can test independently. Maybe someone can tell me what to look for in logs based on what I have said.

    I also have about 5 clients using pfsense and no issues at all... one even on 200Mbps fiber with five IPSEC tunnels... ironic that I cannot get running at my own house :)



  • If your modem has the Intel Puma 6 or 7 chipset it could be the reason why.. And looking I see it in fact does. Get something with a Broadcom Chipset..

    Motorola MB8600
    Netgear CM1000
    Arris SB8200 (runs hotter than most)

    http://badmodems.com



  • Quoted From https://forums.xfinity.com/t5/Your-Home-Network/XB6-Modem-Worse-Than-Others/td-p/3046851

    ""
    Re: XB6 Modem Worse Than Others

    Was never sent the third modem and glad I ditched the XB6 for a Motorola MB8600 that I've actually hit speeds in the 900Mbs range that I couldn't with the XB6 or even the SB8200 which I also sent away.

    May want to think twice about the XB6.

    http://www.multichannel.com/news/cable-operators/comcast-taps-arris-technicolor-xb6-gateways-sources...

    http://badmodems.com/Forum/app.php/badmodems

    ""



  • I know XB6 seems to have bad reputation but it works fine with other routers in bridge mode. Must be something pfsense is doing.
    However, Shaw just announced today they double speed of 150 and 300 plans. Now I get 600Mbps so it is possible it is a new firmware and maybe this issue is fixed. I will report back with my findings.

    Failing it being fixed, I can now at least downgrade to the 300Mbps plan and get Hitron Modem which do not have any issues. Telus fibre is to be installed next summer anyways so I will eventually go to that.

    I just received a Netgate SG-5100 in the other day for a customer... what a beast! I would take it home and try but it is being installed in couple days so I don't have any time to play with it really.



  • So I put back my pfsense to XB6 and everything seemed stable after for couple days.
    Only thing is I notice speed isn't as fast as my Cisco RV320. On RV320 I would get up to 649Mbps down, but on my Super Micro rack-mount home-built pfsense router, I only got around 550Mbps.

    Last night I moved my configuration over to the SG-2220 and I get a little better, around 580 and seen it high as 600, which is good enough for me, and consumes less power. No problems so far with WAN not working.