SOLVED! SQUID speed issue



  • Hi ALL!

    When I enable SQUID (v. 2.6.21_08) on fpSense 1.2.2 and try to check bandwidth with www.speedtest.net I notice, that speed lowers from about 2000 Kbs to about 1200 Kbs.

    When I test again without proxy, speed again about 2000 Kbs.

    pfSense hardware is powerful enough, I think. It's ASUS server with P4 2.4GHz/1Gb RAM/160Gb IDE HDD (no RAID)

    No traffic managemeint in SQUID enabled.

    I've tried SQUID 3 beta. Same result.

    What the problem? Misconfig? Normal behavior for SQUID? Something else?



  • Just tried to download new build of pfSenese while SQUID proxy enabled.
    Download speed up to 230 KBs. But speedtest still shows not more than 130KBs. Even less.
    Some other speedtest sites show similar low results with proxy enabled.
    ???



  • Search this forum.  There must be a hundred posts on this topic.  HINT: Many of them are by mhab12…





  • This is easy step-by-step how to solve speed issue of squid:

    You have to edit /boot/loader.conf (diagnostic/edit file from pfSense GUI) and comment (put # in the beginning of line) kern.ipc.nmbclusters="0".
    After this you need to restart squid service (status/services from pfSense GUI) or restart pfSense itself (diagnostic/reboot system from pfSense GUI).

    And now just hope it will help you as it helped me ;)



  • worked for me only after pfsense restarted not just squid service



  • loader.conf will only be read at boot time since it's for kernel configuration.



  • to change immediately you may run```
    sysctl kern.ipc.nmbclusters=8192



  • i have applied the recommanded config and it seeems faster but when i use the speakeasy speed test, it is still at 1M.. hmmmm..


Log in to reply