APU2 BIOS update - cannot boot

  • Running APU2 with 4.0.11 BIOS.
    Tried to update to the latest legacy which is v4.0.21 and found myself trapped as boot just stops at some point

    acpi0: <CORE COREBOOT> on motherboard
    acpi0: Power Button (fixed)
    cpu0: <ACPI CPU> on acpi0
    cpu1: <ACPI CPU> on acpi0
    cpu2: <ACPI CPU> on acpi0
    cpu3: <ACPI CPU> on acpi0
    atrtc0: <AT realtime clock> port 0x70-0x71 irq 8 on acpi0
    atrtc0: registered as a time-of-day clock, resolution 1.000000s
    Event timer "RTC" frequency 32768 Hz quality 0
    attimer0: <AT timer> port 0x40-0x43 irq 0 on acpi0
    Timecounter "i8254" frequency 1193182 Hz quality 0
    Event timer "i8254" frequency 1193182 Hz quality 100
    Timecounter "ACPI-safe" frequency 3579545 Hz quality 850
    acpi_timer0: <32-bit timer at 3.579545MHz> port 0x818-0x81b on acpi0
    hpet0: <High Precision Event Timer> iomem 0xfed00000-0xfed003ff on acpi0
    Timecounter "HPET" frequency 14318180 Hz quality 950
    acpi_button0: <Power Button> on acpi0
    pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
    pci0: <ACPI PCI bus> on pcib0

    Had to revert back to 4.0.11
    Is that a known issue?

  • @andrewz hi,
    I'm on this :

    Name pfSense.babiz
    User admin@ (Local Database)
    System PC Engines APU2

    BIOS Vendor: coreboot
    Version: 88a4f96
    Release Date: Mon Mar 7 2016

    no need to update system BIOS at all, for pfSense purpose, version from release date 2016/03/07 works fine.

  • Some progress...
    I was able to successfully update to 4.0.16 :

    Vendor: coreboot
    Version: v4.0.16
    Release Date: Fri Apr 6 2018 

    Probably something is wrong with 4.0.21
    For some reasons 4.0.16 is shown as the latest available in https://github.com/pcengines/release_manifests/blob/coreboot-4.0.x/CHANGELOG.md
    But here 4.0.21 is the latest:

  • Lool :D according to me, the newer coreboot is designed primary for new APU4 and APU5 board etc, so is possible to get errors when you upgrade lastest coreboot release on older APU2 board.
    Anyway this kind of problem is only pcengines busines and not deal anything with pfsense software. So better call pcengines staff and notice to her this kind of issue. Open thread like this on pcengines forum will be better choice to figure it out.

  • @AndrewZ did you ever find a solve for this? Having the same issue myself

  • @Pacey101
    solved by upgrading to v4.0.25 some time ago

  • Just updated to v4.0.26. No issues.

Log in to reply