Squid not serving from cache?



  • We are again experiencing an issue where all traffic is flowing through squid and we are even seeing TCP_HIT many times in the access log, however speeds are still limited to our WAN bandwidth.  This happened a few versions back and corrected itself in a new squid version.  Here is the relevant post (now locked?) http://forum.pfsense.org/index.php/topic,9398.0.html  Does anyone know what caused this before or remember the solution?  Can somebody confirm that they are getting LAN like speeds on cached downloads in a similar setup?

    Squid 2.6.21_07 / pfSense 1.2.2 built on Thu Jan 8 22:30:24 EST 2009



  • it also depends on file size, etc… which files are caches by squid... do not expect a 600mb cd image to be cached it you configured maximum object size 20 mb :-)



  • We solved the problem some time ago.  It had to do with updating Squid & pfSense versions several times and restoring a rather dated backup of the old version.  When I did a clean install for another installation, I realized the default options had changed substantially from the backups that I kept loading.  Changing the settings to the 'new defaults' solved our problems.  We're seeing about 14 mB/sec with cached items now.



  • I uninstalled squid and squidguard this morning and reinstalled both packages. Works perfect now.


Log in to reply