Squid kern.ipc.nmbclusters=32768 - seemed to be large improvement here



  • Just wanted to mention that this in the /boot/loader.conf:

    kern.ipc.nmbclusters=32768

    ….as suggested by other threads in this forum seemed to be a night and day difference for me.

    Just curious if others are using this as well - it's a quick thing to try.

    Not sure how to quantify it, but it certainly seems a lot faster.



  • My experience has been that commenting the whole line out gives the best performance…
    #kern.ipc.nmbclusters="0"



  • @mhab12:

    My experience has been that commenting the whole line out gives the best performance…
    #kern.ipc.nmbclusters="0"

    Wonder what value will be used if its commented out. Anyone have any clue what this configuration affects?

    I am using the config that was given awhile ago for improving squid performance. In /boot/loader.conf:

    autoboot_delay="1"
    vm.kmem_size="435544320"
    vm.kmem_size_max="535544320"
    #kern.ipc.nmbclusters="0"
    kern.hz=100
    #for squid
    kern.ipc.nmbclusters="32768"
    kern.maxfiles="65536"
    kern.maxfilesperproc="32768"
    net.inet.ip.portrange.last="65535"



  • freebsd default is 8192, but pfsense default is 0
    if you comment that and reboot.

    sysctl kern.ipc.nmbclusters
    

    That will show your current value which is default unless its being specified in /etc/sysctl.conf

    performance also increase if set in /etc/sysctl.conf according to http://fasterdata.es.net/TCP-tuning/FreeBSD.html

    
    net.inet.tcp.inflight.enable=0
    net.inet.tcp.hostcache.expire=1
    
    

Locked