"Allow default gateway switching" has no effect [2.1.5]



  • (disclaimer: I know that 2.1.5 is a long unsupported version, however at this moment I have no other option)

    • a pfsense box with 1 WAN interface (10.0.0.99) connected to a switch
    • 2 DSL lines (2 modems: 10.0.0.138 and 10.0.0.139) connected to the same switch
    • 2 gateways set on the pfsense box: 10.0.0.139 (default gw) and 10.0.0.138 (considered as backup) - both through the WAN interface
    • .139 has monitoring turned on, .138 is considered always up

    I enabled "Allow default gateway switching" under System - Advanced - Miscellaneous.

    When I unplug .139 from the switch, the gateway is shown as offline, but traffic is not redirected to .138.

    Am I doing something wrong?

    Thanks,
    Petr, CZ


  • Rebel Alliance Developer Netgate

    Having two gateways on the same interface isn't going to work that way. Each WAN needs to be on a separate interface or VLAN in a unique subnet.

    And there were tons of problems with default gateway switching back then, you need to upgrade.



  • Thanks for confirmation of what I feared! :)