Odd pfSense Issue - Acting Like it Reset Itself/Fresh install



  • I have been having this weird issue where when I go to reboot, this happens sometimes, when booting back up i am prompted to enter interfaces when the unit has been setup for a long while. Today it happened again, but where starting last night slowly my network devices started going offline 1 or 2 at a time hours apart where this morning I lost all connectivity and figured I would reboot and then I was prompted to setup VLANs and interfaced like I just installed pfsense. This will be at least the 5th time this has happened. I tried restoring my backup config and when I did and it rebooted I got the same prompts again to setup VLANs and enter interfaces. Really not sure what is happening and where to start as this has been happening only this year and never had this kind of trouble before. If anyone can give me an idea of where to check when this happens to figure out the issue that would be great.


  • Netgate

    Sounds like it could be a failing disk but it seems you would be having far more problems if it was that.

    I would look int he system log for anything that did not look right.

    I would back up the configuration, completely reinstall, and restore the configuration.

    It could also be that you have an interface that is not appearing sometimes and is triggering the interface reassignment. Any USB ethernet, cellular modems, or anything?



  • Today I ended up reinstalling and restoring the backup to get up and running again.

    Luckily all int are inside the unit and no external ints attached. I do have 1 VLAN that I have had setup for sometime and can be removed if that would help. Since I had to wipe and restore I will have to wait until it happens again. I do find it odd that restoring the config did nothing. This issue has happened before, but usually after rebooting or upgrading and I do not notice anything wrong until then, every upgrade I have done except for 1 or 2 resulted in having to reinstall and presented the same results as in acts like all ints are unassigned and I am prompted to setup VLAN and assign interfaces upon boots. Hardware itself has been great, not sure about the SSD, but i do not remember this happening before. When I updated to 2.4.4 this issue happened and had to reinstall fresh and restore. Last night was the oddest time this has happened, it was like a bit ninja was going through my network knocking off network devices and not all of them at once, but 1 maybe 2 at a time over a long period of time and this morning is when I found out anything attached to pfsense lost internet connectivity, but internal routing still worked.



  • What could cause the interfaces to get lost? My VLAN did give itself a interface name of in1.42 and my LAN is in1 and WAN is 0 so may having in1.42 and in1 is causing a conflict that eventually kicks out all the interface assignments, maybe?



  • Did a quick restart and it did it again. I can not reproduce the issue at will


  • Netgate

    What physical interfaces are in the node? I have never heard of in(4) and there is no man page for it.

    If any defined interface is not present when it boots it will kick into interface reassignment.

    Are you sure it's not just doing that and the configuration is actually still there?



  • Sifting through the boot logs and system logs now.

    When I rebooted it prompted to setup VLAN and assign WAN etc...

    Once past that all other config items are there, just the interfaces are all unassigned.

    Ill post once I find something.

    A separate issue I have found is unable to start radiusd through the GUI, can start it via shell with no problem, just wont start using the GUI. When setting up Freeradius3 in 2.4.3 this issue was not present. Only started in 2.4.4. Looking for log info on that as well.