Restore Pfsense backup from 2.2.5 to 2.4.4 then gertting error



  • Hi,

    Currently, we are using 2.2.5 pfsense version and now we want to upgrade to uper version 2.4.4. but while we are restoring the existing backup file on upgrade version then getting an error. Please find the attached Bug logs. please suggest is it possible or not we can restore the backup without error. 0_1543902222988_Pfsense_Error.txt



  • Your 2.2.5 is a 32 bit version.
    Installing 2.4.4 means : you're going to 64 bits. This means : complete re install from media - and wiping the disk where pfSense is installed on.

    When 2.4.4 is up and running, import your config entirely, or by bits and pieces.

    Because you came from 2.2.5 I really advice you to all 2.4.4 release notes.


  • Netgate Administrator

    The crash report shows a file system error that would be independent of the loaded config.

    You can probably recover that by booting into single user mode and running fsck -y / a few times or you could just re-install 2.4.4p1 clean again.
    Usually that happens because of some power interruption during a filesystem write.

    Steve