2.4.4p1 Routing Error


  • Rebel Alliance

    Crazy routing error after updating my SG4860 to 2.4.4 p1.
    I run a number of OpenWRT routers into this central firewall via OpenVPN.
    The WRT devices made OpenVPN connections but the routing was broken.
    I made a quick check and there was nothing obvious, so I rebooted (software) the SG4860 & still no routing.
    I then reloaded the pre-saved config file & all the routing was happy again. - as was I


  • Netgate Administrator

    Did you update from 2.4.4?

    Did you see any package errors? Are you running any packages?

    Steve


  • Rebel Alliance

    @stephenw10
    No obvious errors appeared.
    That said I only quickly browsed the routing settings, and not the the system logs.
    This is my live firewall and I was looking to get it back online ASAP.
    Packages: ACME, Cron, mailreport, nmap, openvpn-client-export, syslog-ng.
    I have static rutes under System/Routing/ .. and Firewall/NAT/Outbound rules for the OpenWRT clients. These routes were not working after the 2.4.4p1 upgrade (& subsequent reboot), but came good after a reload of the config file.



  • @gil said in 2.4.4p1 Routing Error:

    I then reloaded the pre-saved config file

    This doesn't really help this time, but next time it might be informational to save the non-working config file first, and compare it to the saved one.