Ipv6 setup for Telus



  • I have tried to get ipv6 working with pfsense and have had no luck .I am running pfsense from the bridged port 1 on the telus router .



  • This is what worked for me:

    1. Navigate to Interfaces -> WAN
    2. IPv6 configuration should be DHCPv6
    3. Under the DHCP6 config, select “Request only an IPv6 prefix”, prefix size 56, “Do not wait for a RA”, and “Do not allow PD/Address release”.
    4. Under the DHCP config, select advanced configuration and add “supersede dhcp-lease-time 1800;” under Option modifiers. I found this necessary to keep the IPv6 prefix working for longer than a few hours.
    5. Under your LAN interface, select track interface for IPv6, and pick a prefix ID of 0. Other interfaces can use nonzero IDs but I found if I didn’t use zero I would eventually lose the prefix and pfsense wouldn’t recover.

    You could also add some rules to allow the relevant ICMPv6 packets through the firewall.



  • This is what i did and works perfect
    You should have the following WAN settings:
    IPV4: dhcp
    IPV6: dhcp6
    request prefix only
    /56 prefix
    do not wait for ra
    do not allow pd release
    You should have the following LAN settings:
    ipv4: static
    ipv6: track interface
    upstream gateway: none
    track ipv6 interface: WAN



  • The latest pfsense patch seems to have broken something. Can’t get an ipv6 address at all now. Don’t have time to debug it now but maybe in a few weeks I’ll look into it.



  • @eternalglue Works fine here no problems at all



  • The latest update works for me too. I'm on Rogers.



  • A reboot fixed it. Not sure what was going on, but an error in the system logs said something like “couldn’t allocate interface”. Wish I’d saved it now.



  • @eternalglue said in Ipv6 setup for Telus:

    This is what worked for me:

    1. Navigate to Interfaces -> WAN
    2. IPv6 configuration should be DHCPv6
    3. Under the DHCP6 config, select “Request only an IPv6 prefix”, prefix size 56, “Do not wait for a RA”, and “Do not allow PD/Address release”.
    4. Under the DHCP config, select advanced configuration and add “supersede dhcp-lease-time 1800;” under Option modifiers. I found this necessary to keep the IPv6 prefix working for longer than a few hours.
    5. Under your LAN interface, select track interface for IPv6, and pick a prefix ID of 0. Other interfaces can use nonzero IDs but I found if I didn’t use zero I would eventually lose the prefix and pfsense wouldn’t recover.

    You could also add some rules to allow the relevant ICMPv6 packets through the firewall.

    Just noticed this thread about Telus. Telus has played with lease times quite a bit. Lately, at least for DSL, the lease time is 10 minutes, so you will see it renew every 5 minutes. This happens in the background, so it makes no difference to the service.

    The only mandatory settings for Telus are: request prefix only, /56 prefix, and do not wait for ra.

    It's not strictly necessary to use do not allow pd release, unless you want the dynamic prefix to be as stable as possible. Telus will delegate the same prefix to the same DUID, unless another system requested a prefix while there was no active lease on it. The only difference do not allow pd release makes is that the prefix won't go back into the queue immediately, it will go back in after it expires. That's 10 minutes (BFD). In practice, if you keep your system running, the prefix won't change. As long as you keep an active lease on it, the prefix will stay the same.


Log in to reply