How do I disable RAM drive for /var /tmp?



  • I stupidly enabled the RAM drive option for /var and /tmp in preparation for moving to an SSD without realizing I had wiped all my config backups and didn't take a new one. When booting, I'm immediately greeted with errors that it cannot write to /var or /tmp because the filesystem is full. The web interface won't start and don't see the normal console options after reboot, though I am presented with a login prompt and can login successfully. Is there a way I can disable this at the console?


  • Rebel Alliance Developer Netgate

    You could hand-edit the config with viconfig, or with another editor like ee and then rm /tmp/config.cache afterward. Once you remove the tag to activate the RAM disks, reboot and it should be back to normal.

    The tag you are looking for is <use_mfs_tmpvar/>