static route with two PPPoE interfaces sharing the same default gw



  • Hi,

    I have two outgoing PPPoE connections from my ISP with fixed IP addresses and the same default gateway, 10.0.0.1 (say interface A and interface B).

    Interface A is the default outgoing interface. I need to have traffic to certain destinations use interface B, so I have added a static route to the outside network and asigned it to gateway B. However, in the resulting routing table the new static rule is bound to the 10.0.0.1 gw (which is correct), but also to interface A instead of B (which is wrong). It looks like the route is configured only based on the default gateway and not the egress interface...

    Is this a bug/error, or am I missing something?

    Thank you!



  • @md0 said in static route with two PPPoE interfaces sharing the same default gw:

    Is this a bug/error, or am I missing something?

    You missed to slap your ISP (or the one who ordered this mess) for giving you two connections with the same gateway.
    Routing through different interfaces can only happen when they have different gateways.

    A transit network in front of your second WAN can help.



  • Hi jahnix,

    I agree that it's not an ideal situation, but I needed a cheap setup with multiple fixed IP addresses. And it works for the most part - for example, traffic to the gw monitoring IPs is correctly assigned to the common gateway and different egress interfaces. Why can't this be applied to static routes too?



  • Problem solved: created an outbound NAT rule on interface A that replaced the source address with that of interface B for certain destinations. Since the two interfaces share the same gateway this was not an issue for the ISP - it doesn't care on what PPPoE session a request came from as long as the originating IP address is allowed through the default gateway.