Assistance asked for routing



  • Hi there,

    On my personal computer I have installed VMware Workstation.
    Now when I start VMware Workstation I first added 5 NICs.
    VMNet0 is the one I used to connect to the internet (bridged).
    The other VMNet adapters are all set as Host-only adapters.

    Now I create a new pfSense instance and add those configured NICs to this VM.
    VMNet 0 for the internet connection.
    VMNet 1 has been configured for static addresses: 10.1.1.1/255.255.255.0, which is the pfSense install it self.
    VMNet 2 has been configured for static addresses: 10.1.2.X/255.255.255.0 (Servers)
    VMNet 3 has been configured for DHCP leases with: 10.1.3.X/255.255.255.0 (Clients)
    VMNet 4 has been configured for DHCP leases with: 10.1.4.X/255.255.255.0 (Clients)

    When pfSense is installed I get an IP address to go out on the internet. So that works.
    When I boot a server with VMNet 1 and set the IP address to 10.1.1.2, I am able to open the web interface from pfSense and go on the internet from this server.
    Now when I change the server VMNet1 to VMNet 2 and set the IP address to 10.1.2.1 I cannot reach the pfSense web interface nor I can communicate with the internet.

    The VMNet 3 and 4 are both DHCP and they handout IP address to the clients that come online. But also not possible to go on the internet. In pfSense under DHCP > Clients I tried to add the Gateway to 10.1.1.1, but this gives me an error:

    • The gateway address 10.1.1.1 does not lie within the chosen interface's subnet.
    • The broadcast address cannot be used in the ending subnet range.

    I am myself aware that I am missing some settings that need to be added but I cannot figure out which these are. There for I would like to ask for some help or guidance how to resolve this issue. If any further information is required please let me know.

    Thank you all in advanced



  • https://www.netgate.com/docs/pfsense/routing/connectivity-troubleshooting.html probably missing or wrong rules on the additional LAN interfaces.



  • Grimson, thank you for your feedback. This just was the little piece of advice I needed. I got it working now thanks!

    Topic can be closed.


Log in to reply