Upgrade from 2.3.1 to 2.4.4, PHP errors all over the place



  • Hey, This topic might have been covered before, but I could not find one solution that worked. Here is the deal,

    1st of all, I am new to this community, So please push me towards the right direction if you don't have the answer to my issue.

    I've been using this device https://www.amazon.com/gp/product/B00JS6YZYO/ref=oh_aui_detailpage_o02_s00?ie=UTF8&psc=1 for the past couple of years. here are the details if you dont want to click on the link: Mini ITX pfSense Router/Firewall with 5x Gbe LAN, 32Gb SATA SSD pre-loaded with 64 bit pfSense 2.1

    I've manage to update it to 2.3.1, after which, the device was unable to fetch new updates from the server using the GUI update tab. I've recently decided to upgrade to 2.4 as it is working beautifully on my VM machine at home. Here's the problem

    PROBLEM: After sshing into the device and selecting 13. The router started the update process, the returned to the menu. The router didnt reboot or anything. So I decided to check if it updated or not, ran 13 again (Update process) began again, but this time, it finished much faster, and started throwing PHP Warnings, lost connectivity to my GUI portal, and stopped routing all together. I cannot connect to it via SSH, So I decided to go to the rack room, where I connected it to a monitor using VGA, same PHP errors. The box has no connectivity to the internet, eventhough 4 WAN connections are hooked up to it.

    Here is what i've tried so far:
    Downloaded the latest version 2.4.4-p1 from the website, flashed it to a usb drive. plugged it in, reboot loop. looked for an older version, 2.1.5, flashed it, it worked, and one of the WAN ports was working as well, was able to ping google, but was unable to connect it using the GUI, nor was I able to ssh to the box.

    Question: is there a way where I can download an older version 2.3.x maybe and restore my old config there? I could not find a proper mirror. Any help would be much appreciated.

    Thank you


  • Netgate Administrator

    2.4.4 should load on that OK. Where was it looping? Was there a panic?

    If you upgrade and see library errors try this:
    https://www.netgate.com/docs/pfsense/install/upgrade-troubleshooting.html#upgrade-not-offered-library-errors

    Steve



  • Thank you for you reply Stephen, The problem is that the box has no connectivity whatsoever so pkg-static will not work. All I can select from the CLI menu are both options 9 and 8.

    Option 9 shows nothing. Option 8 gets me in the shell, but theres not much that I can do there as far as I know.


  • Netgate Administrator

    From 2.1.5 or the upgraded 2.4.4p1?

    I would try to make it boot 2.4.4p1 directly, that's the path to getting up and running and being able to re-install etc.

    Were you able to note where it it is looping?

    Steve



  • The boot loop occurs when I plug in the 2.4.4p1 memstick. The computer goes to the boot sequence and reboots before getting to the pfsense boot loader menu.

    2.1.5 worked fine. But I didn’t want to install it on the box. It’ll be my last resort.



  • Just restored to 2.3.5 uploaded my config.xml backup, and everything is up and running. Too scared to update to 2.4.4.

    Seems like things are good now. I managed to find a working mirror with older versions. I dont know if it is against the rules to share, so If anyone needs them, just dm me, and ill be happy to share.

    Thank you Stephen for your help


  • Netgate Administrator

    If you're able to capture the boot sequence from the 2.4.4p1 installer I'd be interested ti see it. There doesn't look to be anything special about that system.

    Steve



  • @comthre3 said in Upgrade from 2.3.1 to 2.4.4, PHP errors all over the place:

    working mirror with older versions

    I had looked yesterday and found the /mirror/downloads/old/ directory showed a 403 error on the mirrors I looked at. We hadn't been keeping older versions downloaded, but may need to if they aren't readily available. What mirror did you find still offered them?

    after which, the device was unable to fetch new updates from the server using the GUI update tab

    I had issues on several 2.3.x installs with updates not working...changing to the development branch and back again seemed to fix it. See https://forum.netgate.com/topic/111872/2-3-3-is-live/21 (phil.davis post) for that issue.



  • It turns out I got into a similar situation. I've upgraded several routers, ours and clients, to 2.4.4 and 2.4.4_1 recently. Last night I tried updating a SG-3100 from 2.4.3_1 and the GUI kept showing a "failed" message during the update and/or downloading, but no actual errors were shown that I saw. I tried a couple of times, and eventually it finished, and restarted, but didn't come up. Today on site I could not ping the LAN IP showing in the console, and the console showed 2.4.4_1 installed but all sorts of PHP errors for missing libraries and so forth (I didn't document them). The short version is I ended up reinstalling from the SG-3100 "factory" image for 2.4.4_1 (https://www.netgate.com/docs/pfsense/book/install/download-installer-image.html) via USB stick and it seems fine now.

    A while back I seem to recall someone posting that the update could "fail" but still be processing in the background and the router restart eventually and upgrade fine...I'm wondering if something like that happened and I didn't wait for the reboot.


Log in to reply