Boot halts on #



  • 0_1544513345213_#_prompt.jpg

    ng over This morning I was swapping over to my redundant box for updating and accidentally pushed the rest button (i was not updating as the time it was running normally) the front of the box. The box subsequently rebooted and halts on the # sign.

    Any ideas as to my course of action. Is there a command I can run to fix whatever has caused this?

    Hopefully someone has encountered this before and can help.



  • @zoqask It says.. / not properly dismounted and refuses to mount
    You need to repair the filesystem.
    Typically fsck.
    Another option is to boot from pf install media and try to salvage the config.xml
    And then reinstall.



  • 0_1544515847537_#_prompt_fsck.jpg
    Thanks. I ran the command and also tried the -y flag. Can you make sense of attached?



  • @zoqask Well it looks like a report but no fix. Maybe fsck -f -y
    Do tou have a config backup?
    Fsck seems to run in readonly mode.



  • No such luck. I will have to re-install. Yes I have the config backed up. Next time I will pay more attention to the buttons on the fascia. Whatever I did has snafued the file system.



  • @zoqask It is strange that fsck -y operates in readonly mode.
    But its not worth the investgation.
    Restoring the config is way faster and within a predictable time frame.


  • Rebel Alliance Developer Netgate

    fsck requires read-only mode because it operates on the filesystem metadata directly. A read-write filesystem could change in the middle of a fsck operation and break it worse.


Log in to reply