[Resolvido] - Problemas com configuração do OpenVPN Client



  • Ola amigos,
    venho recorrer ao forum novamente porque estou a dias tentando entender um esquema que está me tirando o sono.

    Tenho o seguinte esquema de rede.

    GW01 com duas WAN (wan1 e opt1)
    GW02 com duas WAN (wan1 e opt1)

    E estou montando um serviço de túnel openVPN entre os 2 GW's.
    Preciso que o trafego internet sempre saia pela WAN1 e a VPN sempre pela OPT1, isso tanto no server quando no client.

    Do lado do server, eu fiz o esquema de jogar o trafego para localhost com NAT e na interface do servidor eu coloquei o localhost. Funciona bem...

    Redirect OPENVPN para localhost
    alt text

    Seleciona Interface localhost
    alt text

    Do lado do cliente eu criei um grupo de gateways para failover:

    W1failverW2 onde:
    wan1 tier 1
    opt1 tier 2
    lan tier 3 (estou usando pfsense 2.44_1 (mudou o esquema do default gateway)

    W2failverW1
    wan1 tier 2
    opt1 tier 1
    lan tier 3

    Ficou assim no pfsense:
    alt text

    W1failoverW2 -- define GVT como default gw
    W2failoverW1 -- define Horizons como default gw

    Na imagem abaixo podemos ver que foi selecionado GWGVT como default gateway, através do W1failoverW2
    alt text

    Assim, na configuração do openvpn client eu escolho na interface o W2failoverW1, porque eu quero que o trafego saia pela opt1.

    alt text

    Pelo que entendo, escolhendo o W2failoverW1 era para o trafego da VPN sair pelo link OPT1 (Horizons)

    No entanto, quando subo a VPN e entro em STATUS > OPENVPN, ele monstra local como o IP go gateway da opt1...

    alt text

    Mostra que pegou o IP da OPT1, como eu pretendia.

    Mas no servidor em (peer to peer server instance statistics) está chegando o IP da wan1 do cliente.

    alt text

    Ou seja, pega o IP da GVT que é meu default gateway. Ele não obedece a saída configurada no client.

    Já tentei de tudo pra trazer o IP da opt1, mas não vem...

    Gostaria de saber se isso é um BUG ou tenho que fazer algo mais além de configurar o openvpn client pro trafego sair pela opt1?

    Desde já agradeço a ajuda...

    Marco



  • Senhores consegui resolver essa questão de saida do openvpn client pela interface correta.

    Para que o OPENVPN consiga sair pela interface correta é preciso colocar a seguinte linha em Advanced Configuration > Custom options:

    redirect-gateway local;

    Isso força o openvpn client sair pela interface seleciona na configuração, mesmo em Gateway Groups + CARP.

    Funcionou bem.

    Agora minha Internet sai pela WAN1 e toda VPN sai pela WAN2... caso uma das duas cai, em qualquer dos lados da minha VPN Peer-to-Peer o trafego é remanejado.

    Obrigado.


Log in to reply