New Shaw Modem (XB6) Getting Very Slow VPN Speed



  • Dear PFsense Community,

    I recently got a new XB6 modem due to internet plan upgrade and I am getting slow speed when VPN is turned on.

    • With no VPN turned on I am getting the full 600+mbps.
    • But with VPN turned on, I am getting 80-110mbps (somtimes less).
    • On my previous old modem, the hitron one - I was getting the maximum 300mbps with the VPN turned on. All my settings are the exact same on the VPN side.

    some information:

    • I am running private internet access via openvpn on the pfsense box
    • I am running my xb6 modem in bridge mode (same as my hitron modem)
    • I am running the latest version of pfsense 2.4.4-release-p1
    • I am using private internet access VPN service
    • I am using same VPN settings as when I had my old Hitron modem installed (some basis settings: UDP on IPv4, port 1198, encryption algo (aes-128-cbc), compression disabled, custom options (verb 5; remote-cert-tls server)

    I have made a ticket with private internet access and made a post with shaw. Any useful information I will put here incase it can help someone in the future. If anyone has any recommendations or ideas please let me know. It will be greatly appreciated.

    Thank you!



  • Start here. Your modem can slow to a crawl with UDP traffic..

    http://badmodems.com/



  • I had issue with XB6 where my wan traffic would just stop flowing periodically but no interfaces would drop. This is trying about 4 different pfsense hardware configurations including an sg-2220. When I first upgraded to 300 it worked fine for a few weeks and then problem started. Been running a different router ever since but last week when Shaw doubled speeds I tried pfsense and is stable again.

    Currently using my 2220 again and has been very stable, however with the 2220 I barely get 600Mbps where other router was around 650 - but seems like it fixed itself. If there is issue just go back to Hitron because they now do 300 which is probably fine - I don’t notice difference between 300 and 600 and I still don’t trust XB6 100% and will switch to Hitron if any issue comes up again. It’s not worth trying to troubleshoot because will get no help from Shaw.



  • So I chatted with shaw support and they are putting the blame on my side. They said it is either my pfsense misconfigured, or something to do with QOS or shape shifting on my pfsense box and the switch. There is nothing they can do to help me they say.

    So, i plugged in a laptop directly into the modem. No more pfsense, no more PIA configuration settings on my pfsense, no switch, no QOS, no shape shifting, etc... and I am getting even slow speeds on the VPN client that you can download for windows.

    Here is my tests:

    internet 150 plan w/ Hitron modem gets 300mbps on VPN
    internet 150 plan w/ Hitron modem gets 300mbps without VPN

    internet 300 plan w/ xb6 modem gets 200 mbps on VPN
    internet 300 plan w/ xb6 modem gets 600 mbps without VPN

    internet 300 plan w/ xb6 modem connected directly to a laptop gets less than 100 mbps on VPN
    internet 300 plan w/ xb6 modem connected directly to a laptop gets 600 mbps without VPN

    Now, I am paying more money for a 600mbps plan than my old plan while getting 100 mbps LESS download speed than my old internet 150 plan (I am getting 200mbps on my VPN with new plan vs 300 mbps on my VPN with the old plan)

    I also spoke to PIA support and they are saying that it is a ISP / Modem issue.

    Very frustrating...



  • @brians Hey brians, they said the hitron-2250 modem can only reach 300 mbps so I would basically have to downgrade back to internet 150 plan. :(



  • Of coarse they did.

    Youtube Video



  • @chpalmer Thank you chpalmer. The information is helpful - but what should I do? I don't think SHAW uses any other modem for the 600 mbps according to the tech I spoke to.



  • This post is deleted!


  • Just an update:

    after hours going back and forth with my ISP provider, they are unable to help me.

    Some success:

    However, after researching I was able to reach near 500mbps with the VPN turned on by creating 4 openvpn clients and putting them into a gateway group.

    these are the custom settings i have for each openvpn client:

    auth-user-pass /etc/openvpn-password.txt;
    remote-cert-tls server;
    reneg-sec 0;
    resolv-retry infinite;
    persist-key;
    persist-tun;
    tls-client;
    pull-filter ignore "auth-token";
    sndbuf 1500000;
    rcvbuf 1500000;

    Problem:

    But I am getting weird long lag / delays. For example, I open starcraft and lots of the images, etc are blank waiting for load. After maybe 15-20seconds it will all load. Or if I am in a party and a game is started, I won't see the invite pop-up. Or youtube seems to load slow, and the images. Same with popcorn time.

    Anyone have any ideas about the weird delays and lags I am experiencing despite getting near 500 mbps download speeds?

    Thank you as always.


Log in to reply