Traffic Shaping and 80 -> 3128 Transparent Proxy Feature Broke



  • I finally got the transparent proxy feature to enable itself properly. I had to remove the 3128 from the ports then slap the save button in the squid config after enabling transparent proxying, then put 3128 back and hit save again.Later, when I tried to enable traffic shaping I got this error after running the shaper wizard:

    There were error(s) loading the rules: /tmp/rules.debug:545: Rules must be in order: options, normalization, queueing, translation, filteringpfctl: Syntax error in config file: pf rules not loaded - The line in question reads [545]: rdr on xl0 inet proto tcp to !(xl0) port 80 -> (xl0) port 3128…

    I am running cvs_sync.sh releng_1 as of June 24th 23:03 CST

    There were error(s) loading the rules: /tmp/rules.debug:545: Rules must be in order: options, normalization, queueing, translation, filteringpfctl: Syntax error in config file: pf rules not loaded - The line in question reads [545]: rdr on xl0 inet proto tcp to !(xl0) port 80 -> (xl0) port 3128…

    Is there a quick fix for this?

    Thanks.

    p.s. a different but somewhat related problem is that squid won't stay running if I start it from the services menu, but if I start it manually from the command line it starts up just fine with no errors. I assume the services script isn't working quite properly. I tried out the current HEAD release and it broke PPOE filter order badly so PPOE wouldn't work. So I don't know if it's fixed in HEAD yet.


Log in to reply