IPTV returns 401 after latest update



  • The IPTV service that I was using worked perfectly before the latest update. Then after the update it started giving me only 401's. All my devices are behind a paid VPN provider through my pfsense installation.

    > User-Agent: curl/7.54.0
    > Accept: */*
    >
    < HTTP/1.1 401 Unauthorized
    < Server: SERVER
    < Date: Sun, 16 Dec 2018 20:13:44 GMT
    < Content-Type: text/html; charset=UTF-8
    < Transfer-Encoding: chunked
    < Connection: keep-alive
    < Access-Control-Allow-Origin: *
    

    If I connect straight to my direct Internet connection, I can access it perfectly fine.

    > User-Agent: curl/7.54.0
    > Accept: */*
    >
    < HTTP/1.1 302 Found
    < Server: SERVER
    < Date: Sun, 16 Dec 2018 20:13:28 GMT
    < Content-Type: text/html; charset=UTF-8
    < Transfer-Encoding: chunked
    < Connection: keep-alive
    < Access-Control-Allow-Origin: *
    

    As I'm not a network engineer, I have no idea where to start looking for and I hope someone can give me a push into the right direction. DNS configuration? Firewall rules? Something else?

    Thank you in advance!


  • Netgate Administrator

    What did you update from?

    How do you have this setup? Did you have any special configuration to enable IPTV to work through pfSense?

    Steve



  • I came from the version before 2.4.4-RELEASE-p1 (which is now my current version).

    Internet connected to pfsense (19" rack build).
    Wifi connected to the pfsense.
    pfsense making use of a VPN tunnel to a paid provider on opt1.

    I have nothing special regarding the IPTV setup. Just copy+paste a link into VLC.

    Any hints of what might be the case? I cannot find much in the logs unfortunately.


  • Netgate Administrator

    Ah, OK and the IPTV stream is being accessed over the VPN when pfSense is in play?

    Most likely the IPTV service has blacklisted the VPN providers IPs as the source of either hack attempts or users bypassing geo restrictions.

    Try disabling the VPN and testing through pfSense.

    Steve


Log in to reply