Vmware virtual and "connection interrupted" error bizzareness!! (help!)



  • Ok here we go,

    Ubuntu 8.04.2 server - vmware 1.08 - pfsense 2.2  and a cable modem

    I've configured a vmware virtual of pfsense before and its worked 100%. I've depreciated the old bit of hardware that was running the vm host and moved it into another PC which has other virtuals on it as  it has space. For the record no other virtuals are currently running on this box, just pfsense.

    Heres whats been done.

    Vmnet 0 = eth0 bridged
    vmnet 2 = eth1 bridged

    pfsense le0 = WAN (le0 ->vmnet 0 -> eth0) (DHCP)
    pfsense le1 = LAN (le1->vment1->eth1) (192.168.0.1)

    I've configured the mac spoofing on the WAN as without it the cable modem wont talk to me!

    The VM host has access to the internet and everything is ok.

    The DHCP clients on the /24 network can ping google and can ping each other however when you go to connect to google via firefox I get "connection interrupted" and it appears as if it can't setup a tcp session.

    I can ping from a client machine no problems , can ping servers by DNS name on the internet fine I jsut can't connect. But if I connect form the VM host all is fine….

    I've not seent his before, I've reinstalled everything twice (vmware / pf) just to make sure I'm going about it correctly but its just not working. I'm at a bit of a loss as to what I've missed ....anyone shed some light on this. I can't go back to my previous virtual as a stupidly deleted it thinking everything would work fine...HA ha fail!



  • ive not fixed the issue but I've managed to at least get connectivity.

    I found that if I do a /etc/init.d/networking force-reload (which is ipdown -a –exclude=lo and ipup -a --exclude=lo ) on the VM host then all is well ! What I found was that this will stay persistant when the virtual is rebooted but not the host :(
    I've not found a way to successfully script this to happen after boot even with script that will perform the required actions after a fixed amount of time..say 10 minutes which is more than enough for the box to reboot and raise the virutal.

    I've installed VM tool onto the pfsense box and that's made no difference. It seems to be either a problem with the host NIC or the vm driver that performs the briding. I could really do with some input and I'd like to know if someone has suffered this before.



  • :(

    [SOLVED!]
    right i've fixed it! I moved the virtual onto another PC that had dual onboard nics. One a Marvell tech nic and the other an Nvidia Nic (see where I'm going here?). I disabled the Nvidia Nic in the bios and slapped a spare  3Com card I had lying around into a PCI slot and presto worked first time!

    Looks like the forcedeth driver doesn't play well will vmware on ubuntu 8.04.2, I'm kicking myself as I usually make sure the hardware is solid because I know how twitchy vmware is with network hardware…It worked fist time so I'll be switiching out the 3scom for 2x netgear at some point!!!!


Log in to reply