NAT não funciona



  • Tudo bem pessoal?

    Estou a 5 dias pesquisando, instalando o Pfsense 2.4.4p1 como VM, direto no servidor, testando outras versões e nada da minha NAT funcionar.

    Vi configurações de NAT em vídeos do Youtube, aqui no fórum, na internet, todas parecidas e nada de funcionar.

    Tenho um IP publico e um servidor com a porta 80.
    Quero redirecionar acessos externos para ele.

    Isso já funciona no mesmo roteador da operadora que temos em linux, modo texto com iptables, mas no Pfsense não funciona nem a porrete...

    Será que alguém poderia me ajudar? Parece tão simples mas não funciona aqui.

    Pra constar, um dos status de conexão estava CLOSED:SYN_SENT ao tentar acessar da minha maquina por outra internet.

    Obrigado.



  • This post is deleted!


  • Tentou acessar por uma porta diferente (ex.: 8880) e redirecionar para a porta 80 do servidor que deseja acessar?



  • Atualmente temos um uma faixa de ips públicos que através de um dos ips, sendo usado como virtual, redireciona solicitações externas para a porta 80 de um servidor interno.Isso com o iptables em Ubuntu.

    No pfsense, seguindo tutoriais para criar uma regra nat, isso não funciona...

    Consigo por exemplo desbloquear a porta 80 de um IP virtual no pfsense pelo firewall, rules, mas quando aplico uma Nat ela bloqueia a porta.

    Já testei muita coisa...
    Pro Nat funcionar, é só configurar a regra ou tem que ativar algo mais? Já tentei ativar algumas opções referentes ao Natal mas continuou não funcionando.



  • Normalmente é apenas criar o nat.

    Mas faça esse teste, crie uma NAT com uma porta alta e redireciona para o ip e porta 80. depois refaça o teste.

    Um teste a mais depois de tantos não vai fazer diferença.. rsrs...



  • Bom dia!

    Testei da 8080 para a 80 e não funciona...

    Deve ter algum "pulo do gato" pra habilitar isso, não é possível...rs

    Pelo que vi é um processo tão simples, não faço ideia pq não está funcionando.



  • @rubens-fontes Quando vc criar o NAT, vc percebe que se cria uma regra no FIREWALL, essa regra vc mantem ela aberta no FIREWALL ???



  • Boa tarde!

    Sim. Quando crio uma regra NAT, automaticamente é criada uma regra no firewall.

    Em carater de teste, criei regras apenas no firewall e os pings ou testes de porta externos funcionavam... Quando eu criava a NAT para a mesma porta, bloqueava...

    Além de só setar o NAT, tem algum serviço ou opção que deve ser habilitado para que o NAT funcione?



  • @rubens-fontes Post um preent de como esta suas regras no FIREWAL>> WAN
    Para analisarmos.



  • Seu serviço precisa apenas da porta 80? Eu tenho um dispositivo que precisei fazer duas NAT, uma que direcionei uma porta alta para a porta 80, e a outra porta que ele precisou que foi a 3501 para a 3501.

    Tenta um número diferente 14980 por exemplo, 8080 é um valor um pouco utilizado em alguns serviços ai vai que coincidiu com algum serviço ai.



  • Sim, porta 80, HTTP. É um site simples.

    Cheguei a fazer esse teste de usar outra porta mas tb não consegui, tem alguma coisa bloqueando.



  • Então, vou explicar melhor.

    Já tenho um IP público que funciona com o redirecionamento em iptables para esse servidor interno.
    Se eu digitar o ip público/site a página abre.

    Estou tentando usar outro ip público que possuo para teste no pfsense, redirecionando para esse mesmo servidor interno e site...

    0_1546536289859_41e40d93-5f62-4501-9c81-97641a22e28e-image.png

    0_1546536314189_9b121e6e-5100-487e-9ebb-0468c384693b-image.png



  • aparentemente está correto!!!!
    use protocolo TCP/UDP.

    Vc consegue acessar o pfSense externamente. (So abrir no FIREWALL>>WAN a porta do webadmin do pfsense, caso vc utilizar porta).

    faça o teste!



  • Criar uma regra para a porta do webadmin? Qual porta, a 443?

    0_1546537932796_0b629d11-b9f3-4a56-9cef-1528027c322e-image.png



  • @rubens-fontes Isso ... como vc usa https.... abre a 443 na WAN.. e faça um teste.



  • Deu certo!
    Acessei o pfsense na 443 pelo ip publico da wan.

    O redirecionamento NAT que não vai...



  • @rubens-fontes Ótimo isso é um bom sinal!!!
    O que vc esta tentando redirecionar na porta 80?? site ?



  • Bom dia!

    Isso! Tem um site simples rodando em apache e redirecionamos externamente também para download de alguns softwares.

    Atualmente funciona com o iptables em Ubuntu.



  • Ainda não consegui.

    Regras de porta setadas apenas no firewall, funcionam bem. Acessei a console do Pfsense externamente.
    Porém ao colocar algum encaminhamento em NAT, nada funciona...


Log in to reply