pfSense and Nexcom DNA120



  • Hi, I have a decommissioned but functional Nexcom DNA120 with 64GB SSD, 4GB RAM and Intel Atom E3827 Dual Core @ 1.74. It was previously running Sophos 9.5. I tried to install the latest 2.4.4-p1 using a USB stick. I can see the pfSense installation menu and allowed the default installation but it went into a non-stop rebooting cycle. I hope if anyone can give me some pointers. Perhaps my hardware is not suitable for pfSense?


  • Netgate Administrator

    It probably can run pfSense. Can you see where it's rebooting?

    Does it complete the install?

    If you repeat the install does it do exactly the same thing?

    Steve



  • Hi Steve, all I see is the install menu and then a few seconds later the defaults kicked-in. There were 2 lines of codes and the word "rebooting". Then it rebooted and the cycle begins again.
    BTW, I have a small amount experience with pfSense as I have used it for more than a year a while ago. I ran it on a spare machine per my signature. Then I ran Win Server 2012 to replace pfSense since then until now. Thinking of getting back to pfSense using a low wattage machine.


  • Netgate Administrator

    @dreamerman said in pfSense and Nexcom DNA120:

    Then I ran Win Server 2012 to replace pfSense

    😱

    Well glad you saw (pf) sense. 😁

    Ok, so which image exactly were you using to install from?

    When you say the install menu do you mean actually in the installer or the boot-loader menu?

    Steve



  • Hi Steve, sorry I went away for a few days with my family.

    The image is pfSense-CE-memstick-2.4.4-RELEASE-p1-amd64.img and verified the checksum. I used rufus to create the bootable thumb drive.

    The error message when I tried to install it is per link. I booted it with the USB drive and allowed pfSense to select the default installation. It just kept rebooting.

    https://imgur.com/a/vs5uZzP



  • I wonder if it is due to the BIOS settings. I have no idea how to check. Screenshot of the BIOS is as follows. On the opnsense forum, someone successfully installed opnsense on Sophos SG 115 (similar to my unit) by disabling Port 60/64 Emulation in BIOS setting. I tried that and still unsuccessful with pfSense.

    https://imgur.com/a/Js1aUhK



  • I just tried to install opnsense and disabled the Port 60/64 Emulation in BIOS setting. The installation seems to complete without any errors. I hope I can install pfSense as I have used it before but will settle for opnsense if I can't get pfSense to work with my hardware.
    30mins later: I just realised that opnsense is a fork of pfSense. I hope there is no sensitivity in this forum with opnsense and I just trying to get my box to work.


  • Netgate Administrator

    Seems like you're hitting the legacy console issue which is known in 2.4.4+ though it would not normally reboot by itself.

    Either boot the device in UEFI node which should give a working console or do this:

    https://www.netgate.com/docs/pfsense/install/upgrade-guide.html#upgrading-from-versions-older-than-pfsense-2-4-4
    Specifically the section regarding Atom systems with Intel HD graphics.

    In your case your device appears to have a serial console so you could also install using that which does not have this problem.

    Steve