pfSense router not connecting after update



  • So, is there a way to check the Transcend 8GB 10 microSD HC card has a working pfSense operating system on it?
    The computer sees the card as /dev/sdc.



  • @eiger3970-0 said in pfSense router not connecting after update:

    ALIX-APU-1C4-AMD-G-Series-T40E

    Found the doc.
    Also the operating manual https://pcengines.ch/pdf/apu1.pdf

    There is a serial "RS232" bull modem cable access.
    A soon as the cable access works (a serial cable can not be connected to a VGA screen - it should be connected to a serial cable plug on your PC, or you use a Serial to USB converter) you have access to the boot sequence of your device.
    If pfSense boots, you will wind up with a screen like this :

    pfSense - Netgate Device ID: 20bb46df95386fe7e087
    
    *** Welcome to pfSense 2.4.4-RELEASE-p1 (amd64) on pfsense ***
    
     WAN (wan)       -> rl0        -> v4/DHCP4: 192.168.10.11/24
     LAN (lan)       -> fxp0       -> v4: 192.168.1.1/24
                                      v6: 2001:470:1f13:5c0:2::1/64
     PORTAL (opt1)   -> sis0       -> v4: 192.168.2.1/24
     HENETV6 (opt2)  -> gif0       -> v6: 2001:470:1ee2:5c0::2/128
     VPN (opt3)      -> ovpns1     -> v4: 192.168.3.1/24
                                      v6: 2001:470:ccea:2::1/64
     OPT4 (opt4)     -> fxp0.10    -> v4: 192.168.9.1/24
    
     0) Logout (SSH only)                  9) pfTop
     1) Assign Interfaces                 10) Filter Logs
     2) Set interface(s) IP address       11) Restart webConfigurator
     3) Reset webConfigurator password    12) PHP shell + pfSense tools
     4) Reset to factory defaults         13) Update from console
     5) Reboot system                     14) Disable Secure Shell (sshd)
     6) Halt system                       15) Restore recent configuration
     7) Ping host                         16) Restart PHP-FPM
     8) Shell
    
    Enter an option:
    

    But you will probably see "problems" that disables the boot.
    You be anything like bad ram, bad disk.
    The system would boot some BIOS first. This BIOS will start setting up the serial connection - see manual for settings. These settings should be the same on your PC, like speed etc.
    The BIOS will find all attached drives, and if one is bootable, it will load the OS from it = pfSense.
    Then the OS kicks in.

    No need to remove the drive and test it : you should check if you can boot (and thus at least : is it readable) from it.

    Btw : myself, I don't use a device like an APU, I have an old PC loaded with network cards, an old fashioned hard disk, it has a graphics card and so my console access is a VGA screen + keyboard : no need to use the serial access.

    edit : See https://forum.netgate.com/topic/138898/apu2c0-usb-install-of-2-4-2-release-fails-with-fatal-trap-9-general-protection-fault-while-in-kernel-mode for another APC thread and an example of the console access.

    https://www.netgate.com/docs/pfsense/solutions/sg-2220/connect-to-console.html

    https://www.netgate.com/docs/pfsense/solutions/apu/index.html



  • Thanks. I tried a serial cable in the router and a USB cable into the computer, however no device recognised.



  • It appears the Linux computer needs the Shell Terminal to have ‘cu’ installed, so the serial cable will read the router.
    This means I have to unbridge the modem so the computer can receive Internet.


  • Rebel Alliance Netgate Administrator

    screen should be installed by default on most linux distro's.



  • Apparently not, unless you know of another program to view via the serial cable?


  • LAYER 8 Netgate

    @eiger3970-0 said in pfSense router not connecting after update:

    It appears the Linux computer needs the Shell Terminal to have ‘cu’ installed, so the serial cable will read the router.
    This means I have to unbridge the modem so the computer can receive Internet.

    Yeah this is the sort of procedure that should be worked out before the firewall fails. It's a good reason to always watch an upgrade on the console. You can see everything that is happening and, if something does go wrong, you have already worked out the console access necessary to see what's happening and you know you have all the parts and software necessary before you need them.

    It is also a good idea to reboot the router once before upgrading because many times it is the restart itself that exposes a bad disk or other hardware issue. The upgrade is almost always blamed though it had nothing to do with the failure.


  • Rebel Alliance Netgate Administrator

    minicom is another, but chances are your syntax is not correct.

    should be something like:

    sudo screen /dev/tty??? 115200



  • Thanks for the alternate command suggestion.
    Unfortunately, screen is also not installed.
    Also, I don’t know the serial cable tty id.


  • LAYER 8 Netgate

    ls -l /dev/tty* ???

    Look at the system log when you connect it?

    Look at the dmesg output and see if, when you boot, the system tells you what tty device node is attached to each serial port?

    Look at the linux manual pages for your distribution for connecting to a serial port?



  • Ok, nothing finds the pfSense router.
    I have the router with a femaleSerial-maleUSB into the computer.
    lsusb and dmesg -w finds no new device.
    I tried the router with maleSerial-femaleSerialAdaptor-femaleSerialAdaptor-maleUSB cable.
    Can't use a serial null modem cable, as the computer has no serial port.


  • Netgate Administrator

    If you see no new USB serial device in dmesg when you connect it then it is the adapter that is the problem.

    I would bet the APU is still just fine in hardware terms. Especially since it's still giving the boot up tune.

    With a functioning serial terminal I imagine it will be obvious when the problem is from the console output. It the very least you can then just try re-installing.

    Steve



  • well, just bought a maleUSBa-maleUSBa and computer doesn't recognise the router.
    Might have to buy a serial null modem cable now.
    Computer has no serial port, so I might join the serial null modem to my femaleSerial-maleUSBa cable.
    I notice the usb has no taste when I put my tongue on it...hope the router is sending power.


  • LAYER 8 Netgate

    You either see the USB serial adapter as a tty port or you don't. You will see this whether or not the adapter is connected to a device.

    The second step would be connecting to the router.

    There is nothing special about the serial console port on an APU other than it is a DTE port like that found on most serial adapters so you need a null modem to connect to it from another DTE port.

    I notice the usb has no taste when I put my tongue on it...hope the router is sending power.

    I have no words in response to this.



  • I bought a serial null modem femaleSerial-femaleSerial cable connected to my maleSerial-maleUSB cable.
    $ dmesg -w, http://dpaste.com/1CN6RJ6


  • LAYER 8 Netgate

    sudo screen /dev/ttyUSB0 115200

    What happens?



  • Bizarre...putty and cu refused connection, but screen worked a charm.


  • Netgate Administrator

    So you were able to re-install or correct the boot fault from the console?

    Steve



  • Had to reinstall on the same working Compact Flash card...it appears the latest update broke the pfSense Operating System on the Compact Flash card.
    Strange, as the router would boot with the beep sounds.
    My tip, have a back up (yes) and have a computer with Wi-Fi (use a hotspot from your mobile to download screen).

    A real hassle to unplug and open up the pfSense router and to unplug the modem which is in bridged mode to the router.
    Then had to plug the bridged modem into the local computer and change the computer to DHCP to find the modem.
    Then plug modem back into the Internet.
    Then connect everything back once pfSense is reinstalled.



  • I have moved this post to my correct original account https://forum.netgate.com/topic/139237/pfsense-router-not-connecting-after-update-continued. Please do not post here.


Locked