BIND GUI is missing field "control port"



  • Hi,
    I have some problems starting BIND and unbound because BIND blocks the control port 953 for unbound if it's starting first.
    So, I wanted to change the BIND control port to something else which should be possible in the GUI
    BIND

    The problem now is, I'm running the same version but I don't have advanced options!?
    alt text

    Can someone tell me why this is and how to solve it?



  • Is this such a complicated question? The wrong sub? Did I do something wrong?



  • Probably nobody knows for sure. Most users here don't use BIND at all.



  • @schossel said in BIND GUI is missing field "control port":

    The wrong sub?

    Yes, bind is a package and package support is here: https://forum.netgate.com/category/16/pfsense-packages



  • True, the manual (of the authors of bind) is a bit cryptic, but the answer is there :

    controls {
    	inet * port 953 allow { localnets; };
    };
    

    in the Global settings bloc (will be put in the named.conf file)
    Change '953' for something else, not used by any other process.

    edit : better example : https://docstore.mik.ua/orelly/networking_2ndEd/dns/ch07_01.htm



  • There's even a patch for exactly this problem (which isn't working "as is" from the github page) which I manually added to the bind.inc and put the control port to 8953. Editing named.conf was somehow not working, because the file is always overwritten on every restart of BIND. I had to edit the bind.inc so that on every restart, BIND is rebuild with the right port. (https://github.com/pfsense/FreeBSD-ports/pull/416). This is quite the action, therefore I would like to change the port in the gui, which seems to be somehow possible.

    Therefore I wanted to know why someone has "advanced options" in the BIND gui when running the same Pfsense version and the same BIND version as I am but I don't have advanced options!?



  • @schossel said in BIND GUI is missing field "control port":

    Therefore I wanted to know why someone has "advanced options" in the BIND gui when running the same Pfsense version and the same BIND version as I am but I don't have advanced options!?

    Well the screenshot displays a "Hide Advanced Options" button, so from a logical point of view there must be "Show Advanced Options" button somewhere if they are hidden. If nothing shows up try a different browser or disable Ad-/Scriptblocking for the pfSense WebUI.



  • The first "black" screenshot is not from me. This was send to me by someone on reddit where I asked how to change the BIND control port. The second "white" screenshot is from my Pfsense where you can see that there is no "show advanced options" or "hide advanced options". That's the reason why I'm asking. It seems to be possible to change the control port in the GUI but I can't figure out how to get this option. Pfsense version and BIND version from me and the one who send me the screenshot are the same. I asked him if he knows how to do it but he says the button was there for him without doing anything since about the last 2 versions eventually longer.

    Call me crazy, I tried 3 different browsers with and without adblocker etc. There's no button "show advanced options".



  • I reinstalled the package and it's now there.

    Screenshot

    I don't know why it wasn't in the first place but thanks for the help!