Error starting DNS Forwarder



  • When I enable DNS Forwarder all defaults and trying to start it, I get error:

    Dec 28 16:41:25 dnsmasq 97060 FAILED to start up
    Dec 28 16:41:25 dnsmasq 97060 failed to create listening socket for port 53: Address already in use

    I’m guessing DNS Resover is using port 53, but not sure what’s the right way to make it work properly?

    Any clues ?

    Thx



  • You have to disable the DNS Resolver if you want to use the DNS Forwarder.





  • @gertjan

    Thx I saw that, but I wouldn’t say it’s very clear.
    What are the steps as you define them?



  • Un-check this one :

    0_1546066071779_a979b6e6-e911-4290-a02b-0cf3b9f82204-image.png

    Then Save and Apply.

    Then check this one :

    0_1546066118339_4ec3809c-b529-47ec-bef7-aa0215ee6647-image.png

    then Save and Apply.

    Also : the Forwarder has to forward to some defined DNS servers.
    These could be the DNS servers your ISP handed over while establishing the WAN connection :

    See the General settings page :

    0_1546066266172_16e14fff-5dcc-490a-9c3c-bb47a8ebfa80-image.png

    Or some other DNS servers like Google or OpenDNS : Example :
    Many people like to send over all their DNS requests to Google (for some obscure reason they insist that Google knows what they are doing - maybe its a $$ issue) : add 8.8.8.8 and 8.8.4.4 and Save.

    My personnel advise is : stay with the Resolver. It works out of the box. Can do DNSSEC. (won't use your ISP DNS servers)



  • @gertjan

    Thank you, will try and likely take your advice


Log in to reply