Rsync issues with 2.4.4-P1 on XG7100



  • Hi There,

    I have two FreeNAS systems, one at home and one at work and pfSense at locations. I use rsync to synchronize a few folders over VPN, this has worked fine until recently when i got the 2.4.4-p1 update on pfSense routers..

    I keep getting these errors after a few minutes rsync: [sender] write error:
    Broken pipe (32)

    Even a ssh connection gets terminated to the remote freenas system after a few minutes

    I have tried over IPSec and over OpenVPN tunnels, both gives the same error.. I have tried taking one of the freenas boxes under my arm and then do a rsync over a direct ethernet connection and that runs without any issues.. I have tried installing a sophos XG at both ends and use that for VPN (IPSec) and rsync runs without any issues..

    So this makes me believe the problems is in my pfSense setup.. It seems to me like my XG7100 closes/terminates my WAN connection after between 5-10 minutes, because downloading a file from rapidgator.net get's interrupted by chrome, that's not an issue with the Sophos either..

    I have installed FRR, pfBlockerNG, HA Proxy, Acme on both pfSense routers

    Any ideas?

    Thanks in advance



  • UPDATE:

    I have made a factory reset on the XG7100, created a VPN tunnel and now Rsync works without any issues.. So that points to something in my configuration.. I will try restore a backup I made before the reset and see how that goes.. I might otherwise have to do a step by step reconfiguration and see if I can find the issue


Log in to reply