IPv6 not working on LAN



  • Hello, I'm trying to transfer from OpenWrt to pfSense. Everything works fine except IPv6.

    The WAN interface can get a working IPv6 address starting with "2001:" without any extra configuration. But the LAN interface can't. Neither do the devices on the LAN Network.

    The WAN IPv6 is set to use DHCPv6 on default, and the LAN IPv6 is set to "track interface". The tracked interface is set to "WAN". But I still can't get a IPv6 address for LAN.

    When I was using OpenWrt, I edited the /etc/config/dhcp as follows: (I only pasted the important lines)

    config dhcp 'lan'
    option interface 'lan'
    option start '100'
    option limit '150'
    option leasetime '12h'
    option dhcpv6 'hybrid'
    option ra 'hybrid'
    option ndp 'hybrid'
    option ra_management '1'

    config dhcp 'wan'
    option interface 'wan'
    option ignore '1'

    config dhcp 'wan6'
    option interface 'wan'
    option dhcpv6 'hybrid'
    option ra 'hybrid'
    option ndp 'hybrid'
    option master '1'

    And that config worked pretty well for me. And is there any suggestions on how to get the IPv6 working on pfSense? Thanks!


  • LAYER 8 Global Moderator

    that doesn't tell us what sort of IPv6 connection your ISP is using..

    Setting your lan dhcpv6 options has really nothing to do with getting IPv6 prefix on your lan side..

    Which setup did you use on your dd-wrt box?
    https://wiki.dd-wrt.com/wiki/index.php/IPv6



  • Thank you for your reply. On ipv6-test.com, it says my IPv6 is Native IPv6 and SLAAC is not used.

    Using that config on OpenWrt, my devices on LAN also get IPv6 addresses starting with “2001:da8:”. The WAN and LAN IPv6 addresses have the same prefix. They can be pinged from the Internet.

    I’m sorry but I didn’t use dd-wrt. But I once used Asuswrt/Merlin. On that firmware, I used “IPv6 Passthrough” and get the same result as I do with OpenWrt.


  • LAYER 8 Global Moderator

    @heartofrainbow said in IPv6 not working on LAN:

    The WAN and LAN IPv6 addresses have the same prefix

    Doesn't work that way..

    your so called passthru mode would be a bridge.. Why don't you call your isp and ask what they support or what is your ISP so we can look it up.

    What are you wanting to do with IPv6 exactly? If you don't even know how your ISP does it, why does it even matter... If you want IPv6 - just get a free tunnel from HE.. Then you can have a /48 and clickity clickity done... Doesn't matter what your ISP supports or doesn't support.


Log in to reply