Failed loading Zend extension 'xdebug.so' after upgrade to 2.4.4-p1



  • Hi!

    I've had trouble updating from 2.4.3 to 2.4.4 recently.
    With a bit of googling, I managed to get it up and running, but I'm now getting errors on the dashboard:

    Crash report begins.  Anonymous machine information:
    
    amd64
    11.2-RELEASE-p4
    FreeBSD 11.2-RELEASE-p4 #2 b00c407ba5d(RELENG_2_4_4): Mon Nov 26 11:41:48 EST 2018     root@buildbot2.nyi.netgate.com:/build/ce-crossbuild-244/obj/amd64/ZfGpH5cd/build/ce-crossbuild-244/pfSense/tmp/FreeBSD-src/sys/pfSense
    
    Crash report details:
    
    PHP Errors:
    [06-Jan-2019 16:51:27 UTC] PHP Warning:  Failed loading Zend extension 'xdebug.so' (tried: /usr/local/lib/php/20170718/xdebug.so (/usr/local/lib/php/20170718/xdebug.so: invalid file format), /usr/local/lib/php/20170718/xdebug.so.so (/usr/local/lib/php/20170718/xdebug.so.so: invalid file format)) in Unknown on line 0
    ------------- (multiple lines deleted) -------------
    [06-Jan-2019 17:48:58 UTC] PHP Warning:  Failed loading Zend extension 'xdebug.so' (tried: /usr/local/lib/php/20170718/xdebug.so (Cannot open "/usr/local/lib/php/20170718/xdebug.so"), /usr/local/lib/php/20170718/xdebug.so.so (Cannot open "/usr/local/lib/php/20170718/xdebug.so.so")) in Unknown on line 0
    
    
    
    No FreeBSD crash data found.
    			
    

    I had a look into the mentioned directory and both xdebug.so and xdebug.so.so have a zero filesize.

    What can I do to fix this issue?

    Kind Regards,

    SnakeZZ


  • Rebel Alliance Developer Netgate

    Those files are not a part of 2.4.4, they must have been left over from something else before the upgrade.

    Make sure there are no files left over for xdebug under /usr/local/etc/php/. If there are, remove them.



  • Hi Jimp,

    there was an ext-20-xdebug.ini there. I moved it out of the way, error seems to be gone.

    Thank you and kind regards,

    SnakeZZ