squid and haproxy not running after minor upgrade



  • I discovered that after doing the minor upgrade from 2.4.4 to 2.4.4_1 two services were not running: haproxy and squid. Manually starting them worked. I also tried a simple reboot from CLI and it seems that after it they are still running.
    I am going to test the other reboot options and be back with full results but this worries me because such event breaks the network configuration: both haproxy and squid being needed services.

    I wonder if anyone else encountered a similar bug.


  • Netgate Administrator

    The packages may have been updating still in the background if you had just run the upgrade.

    Was it just in the Service Status you saw they were stopped?

    I have seen clamav fail to start after a package upgrade before.

    Steve



  • @stephenw10 I was fully stopped, not a timing issue. I figured it out much later because the usage of haproxy/squid is optional. I do not use clamav or other filters, the proxy being 100% for caching.

    Unrelated to the original question one hour ago I found an issue specific to squid: it breaks use of wss:// (web sockets) and so far I was not able to find info about how to avoid it (if is even possible). Clearly this has nothign to do which pfsense.