Pfsense box losing WAN connections when running torrent on LAN [solved]



  • Hello!

    I've recently switched to pfSense. However, I'm facing a serious issue: Whenever I start running a torrent on one of the computers in the LAN, the WAN connection will eventually fail dropping WAN speed to zero and after a bit, coming back again.

    The issue can be seen with following configurations:
    Cisco LRE Box (WAN) <=> pfSense box <-> GigE Switch (D-Link DGS-1008D) <-> PCs on the LAN
    Cisco LRE Box (WAN) <=> pfSense box <-> PC on LAN

    The issue does not exist if the pfsense box is dropped 'from the loop'
    Cisco LRE Box (WAN) <=> PC 'on LAN'

    On the pfSense box itself, nothing really can be seen 'going haywire': state table is hovering at about 1000 and cpu-usage 0-20%, memory is about 10%. I'm a total newbie on all this stuff and don't really know where to start looking for this issue so any help is extremely appreciated :)

    ISP lets me connect to Internet by DHCP or PPPoE and the issue persists on both methods when the pfSense box is there.



  • Alright, I managed to solve the issue. My WAN was on the motherboard's builtin card (broadcomm something) and LAN was on a 3Com PCI card (marvell's chipset iirc). Anyway, I tried something random and swapped the interfaces so that WAN was on the 3Com and LAN was on the builtin and I'm no longer experiencing connectivity issues.


Log in to reply