Upgrade from 2.4.4_1 to 2.4.4_2 error during startup (cannot open /etc/rc.conf: No such file or directory)



  • /etc/rc.conf does not exist.

    How to resolve?

    Best regards,
    Donald.

    ***** FILE SYSTEM IS CLEAN *****
    /dev/ufsid/55e0b2e79f855829: FILE SYSTEM CLEAN; SKIPPING CHECKS
    /dev/ufsid/55e0b2e79f855829: clean, 286587 free (16667 frags, 33740 blocks, 1.6% fragmentation)
    Filesystems are clean, continuing...
    Mounting filesystems...
    random: unblocking device.
    
            __
     _ __  / _|___  ___ _ __  ___  ___
    | '_ \134| |_/ __|/ _ \134 '_ \134/ __|/ _ \134
    | |_) |  _\134__ \134  __/ | | \134__ \134  __/
    | .__/|_| |___/\134___|_| |_|___/\134___|
    |_|
    
    
    Welcome to pfSense 2.4.4-RELEASE (Patch 2)...
    
    No core dumps found.
    ...ELF ldconfig path: /lib /usr/lib /usr/lib/compat /usr/local/lib /usr/local/lib/ipsec /usr/local/lib/perl5/5.26/mach/CORE
    32-bit compatibility ldconfig path: /usr/lib32
    done.
    >>> Removing vital flag from lang/php72... done.
    External config loader 1.0 is now starting... da0s1 da0s1a da0s1b
    Launching the init system...Updating CPU Microcode...
    CPU: Intel(R) Xeon(R) CPU E5-1650 v2 @ 3.50GHz (3500.00-MHz K8-class CPU)
      Origin="GenuineIntel"  Id=0x306e4  Family=0x6  Model=0x3e  Stepping=4
      Features=0x1f8bfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,MMX,FXSR,SSE,SSE2,SS,HTT>
      Features2=0xffba2223<SSE3,PCLMULQDQ,VMX,SSSE3,CX16,PCID,SSE4.1,SSE4.2,x2APIC,POPCNT,TSCDLT,AESNI,XSAVE,OSXSAVE,AVX,F16C,RDRAND,HV>
      AMD Features=0x28100800<SYSCALL,NX,RDTSCP,LM>
      AMD Features2=0x1<LAHF>
      Structured Extended Features=0x283<FSGSBASE,TSCADJ,SMEP,ERMS>
      Structured Extended Features3=0xbc000000<IBPB,STIBP,ARCH_CAP,SSBD>
      IA32_ARCH_CAPS=0xc
      VT-x: PAT,HLT,MTF,PAUSE,EPT,UG,VPID
      TSC: P-state invariant
    Hypervisor: Origin = "VMwareVMware"
    Done.
    ...... done.
    Initializing.................. done.
    Starting device manager (devd)....: cannot open /etc/rc.conf: No such file or directory
    .: cannot open /etc/rc.conf: No such file or directory
    .: cannot open /etc/rc.conf: No such file or directory
    .: cannot open /etc/rc.conf: No such file or directory
    .: cannot open /etc/rc.conf: No such file or directory
    .: cannot open /etc/rc.conf: No such file or directory
    .: cannot open /etc/rc.conf: No such file or directory
    done.
    Loading configuration......done.
    Updating configuration...done.
    Checking config backups consistency.................................done.
    Setting up extended sysctls...done.
    padlock0: No ACE support.
    aesni0: <AES-CBC,AES-XTS,AES-GCM,AES-ICM> on motherboard
    Setting timezone...done.
    Configuring loopback interface...done.
    Starting syslog...done.
    Starting Secure Shell Services...done.
    Setting up interfaces microcode...done.
    Configuring loopback interface...done.
    Creating wireless clone interfaces...done.
    Configuring LAGG interfaces...done.
    Configuring VLAN interfaces...done.
    Configuring QinQ interfaces...done.
    Configuring IPsec VTI interfaces...done.
    Configuring WAN1 interface...
    vmx2: link state changed to UP
    done.
    Configuring LAN interface...
    vmx0: link state changed to UP
    done.
    Configuring WAN2 interface...
    vmx4: link state changed to UP
    done.
    Configuring WAN3 interface...
    vmx6: link state changed to UP
    done.
    Configuring WAN4 interface...
    vmx1: link state changed to UP
    done.
    gif0: link state changed to UP
    gif1: link state changed to UP
    Configuring WAN1IPV6 interface...done.
    Configuring WAN3IPV6 interface...done.
    Configuring CARP settings...done.
    Syncing OpenVPN settings...done.
    pflog0: promiscuous mode enabled
    Configuring firewall..
    gif1: link state changed to DOWN
    gif1: link state changed to UP
    ....done.
    Starting PFLOG...done.
    Setting up gateway monitors...done.
    Setting up static routes...done.
    Setting up DNSs...
    Starting DNS Resolver...done.
    Synchronizing user settings...done.
    Starting webConfigurator...done.
    Configuring CRON...done.
    Starting NTP time client...done.
    Starting DHCP service...done.
    Starting DHCPv6 service...done.
    Configuring firewall......done.
    Configuring IPsec VPN... done
    Generating RRD graphs...done.
    Starting syslog...done.
    Starting CRON... done.
     Starting package Open-VM-Tools...done.
     Starting package nmap...done.
     Starting package acme...done.
     Starting package Service Watchdog...done.
     Starting package squid3...done.
     Starting package haproxy...done.
    ipfw2 (+ipv6) initialized, divert loadable, nat loadable, default to accept, logging disabled
     Starting package pfBlockerNG-devel...done.
     Starting /usr/local/etc/rc.d/c-icap.sh...done.
     Starting /usr/local/etc/rc.d/clamd.sh...done.
     Starting /usr/local/etc/rc.d/pfb_dnsbl.sh...done.
     Starting /usr/local/etc/rc.d/pfb_filter.sh...done.
     Starting /usr/local/etc/rc.d/sqp_monitor.sh...done.
     Starting /usr/local/etc/rc.d/vmware-guestd.sh...done.
     Starting /usr/local/etc/rc.d/vmware-kmod.sh...done.
    pfSense 2.4.4-RELEASE (Patch 2) amd64 Wed Dec 12 07:40:18 EST 2018
    Bootup complete
    VMware memory control driver initialized
    [2.4.4-RELEASE][root@gateway.flissinger.local]/root:
    


  • Do a fresh install and make sure your virtual disk has enough free space for upgrades.



  • pfSense 2.4.4_1 was a fresh install, the virtual disk is 16 GB, that should be enough right?


  • Rebel Alliance Developer Netgate

    pfSense doesn't use that file. Even if it did exist, it would only contain:

    # THIS FILE DOES NOTHING, DO NOT MAKE CONFIG CHANGES HERE
    

    The fact that it is missing makes me wonder if your disk is OK, though. Might have some filesystem corruption or a disk problem.



  • Will install again then, just for sure, thanks!