DNS Resolver (Unbound) + OpenVPN = cannot resolve local resources



  • Hi all,

    Currently running pfSense 2.4.4-RELEASE-p2 and am experiencing an odd issue when it comes to resolving "LAN" resources while connected to my home network via OpenVPN.

    Recently, I migrated from pfBlockerNG to pfBlockerNG-devel and since I wanted to take advantage of DNS Blocking, I migrated from DNS Forwarder to DNS Resolver. My DNS resolver settings are can be found here:

    alt text

    Once connected via OpenVPN (say from work), I am unable to resolve any of my local resources. For example - server name is "storage" and search domain is "home" - ping storage or ping storage.home yields no results (though pinging the IP address gets a resolve). Trying to nslookup the storage or storage.home defaults to my work DNS server; thought if I force using my remote DNS server (dig +short @ip.addr A storage.home) - I do get a proper resolution.

    I've tried the following to no avail:

    • Change Network Interfaces and Outgoing Network Interfaces to use different iterations of WAN/LAN/LOCALHOST with no changes.

    • Disabled DNSSEC - no changes.

    • Added the VPN network in Unbound's Access List - no changes.

    I then disabled pfBlockerNG-devel and Unbound, reverted to DNS Forwarder and right away, everything started functioning as intended.

    Next, went back to Unbound and pfBlocker, rebooted pfSense and for the first few moments - everything worked perfectly! Woohoo! However, shortly thereafter, I was back to square one where it was not resolving any local resources.

    I am a bit a at a loss here - not sure where to proceed. Could someone share some guidance?

    Thanks!



  • Quite odd but it randomly started working again... not sure for how long, though :\



  • Another update: it seems that with every VPN connection, unbound crashed... :(


Log in to reply