DHCPv6 not show leases...



  • Hello.

    Since a week ago I setup 6to4 tunnel to HE and now I can use IPv6... I set up all as written in guide and it works for now...
    Problem is DHCP not showing leases in "Status -> DHCPv6 Leases" At first DHCP wont work and I didn't get IP from it but that's because I set it with /80 or so... When I set /64 for pool it works and I get IP from it... Problem with leases not showing persist...
    What can I do ? Seems all is set properly...



  • Are you sure you're using DHCPv6 to assign addresses? Normally, SLAAC is used, where Router Advertisements advise devices of the network prefix, which the devices then use to create an address by adding 64 bits. The 64 bits could be based on the MAC address or a random number.



  • Dono if it is wise to do so but I'll show you my settings :

    he.net :

    0_1547725193646_ee1c6c12-99dd-4c20-9923-c9b12f31f357-image.png

    Note : back then, in 2014, I was stupid. I followed the guide without thinking ;)
    I shouldn't have take the pie (the Routed /64) , but the entire cake (the Routed /48 which are 65535 parts of /64 pies).

    Anyway, I decided to use the /64 or 2001:470:1f13:5x0::/64 on my pfSense LAN :
    I assigned 2001:470:1f13:5x0::1 (mask 64) on my LAN IPv6.
    I set up the dhcpd6 Server & RA on LAN like this :

    0_1547707964572_b962e61a-3e38-4ffc-b3b8-6803907b772e-image.png

    The "2" in 2001:470:1f13:5x0:2::2 - 2001:470:1f13:5x0:2::88 is just my choice. It could be 0 - 1 - or 3 or up until ffff
    This is my pool. I'm using just a small cut out of the
    2001:470:1f13:5x0:0000:0000:0000:0000 to 2001:470:1f13:5x0:ffff:ffff:ffff:ffff range.

    0_1547708224102_c9d3bfbb-bd9b-4b9f-888b-d259e03f4460-image.png

    I created a list with DHCPv6 Static Mappings, so all my devices (that are IPv6 aware) always have the same IPv6.

    Works for me ™

    Btw : recently, I started to use parts of my 2001:470:xxcea::/48 chunk to attribute a /64 to my VPN interface. Now my road warrior (that me, actually) has a nIPv6 access even when I'm at placse where only IPv4 is available.

    he.net is rock solid. It's happens ones or twice that their Tunnel server - in Paris for me, the '216.66.84.42' goes haywire. They always brings things back up rapidly.
    he.net is a really set it and forget ISP. If you have a good IPv4 ISP, you can have pretty native IPv6 on the fly using toy "/64" and a real "/48".



  • @gertjan said in DHCPv6 not show leases...:

    Dono if it is wise to do so but I'll show you my settings :

    he.net :

    0_1547725193646_ee1c6c12-99dd-4c20-9923-c9b12f31f357-image.png

    Note : back then, in 2014, I was stupid. I followed the guide without thinking ;)
    I shouldn't have take the pie (the Routed /64) , but the entire cake (the Routed /48 which are 65535 parts of /64 pies).

    Anyway, I decided to use the /64 or 2001:470:1f13:5x0::/64 on my pfSense LAN :
    I assigned 2001:470:1f13:5x0::1 (mask 64) on my LAN IPv6.
    I set up the dhcpd6 Server & RA on LAN like this :

    0_1547707964572_b962e61a-3e38-4ffc-b3b8-6803907b772e-image.png

    The "2" in 2001:470:1f13:5x0:2::2 - 2001:470:1f13:5x0:2::88 is just my choice. It could be 0 - 1 - or 3 or up until ffff
    This is my pool. I'm using just a small cut out of the
    2001:470:1f13:5x0:0000:0000:0000:0000 to 2001:470:1f13:5x0:ffff:ffff:ffff:ffff range.

    0_1547708224102_c9d3bfbb-bd9b-4b9f-888b-d259e03f4460-image.png

    I created a list with DHCPv6 Static Mappings, so all my devices (that are IPv6 aware) always have the same IPv6.

    Works for me ™

    Btw : recently, I started to use parts of my 2001:470:xxcea::/48 chunk to attribute a /64 to my VPN interface. Now my road warrior (that me, actually) has a nIPv6 access even when I'm at placse where only IPv4 is available.

    he.net is rock solid. It's happens ones or twice that their Tunnel server - in Paris for me, the '216.66.84.42' goes haywire. They always brings things back up rapidly.
    he.net is a really set it and forget ISP. If you have a good IPv4 ISP, you can have pretty native IPv6 on the fly using toy "/64" and a real "/48".

    Thank you for the answer :) I use some /64 from /48 instead :) All is ok but you also didn't mention anything about main question witch is why Leases are not shown :) I have 4 ISP, 2 of them are at 10Gbit so pretty decent...

    PS Now I see that I have RA Disabled... Will try to change some settings there :) Thank you.


Log in to reply