Cannot load module 'xml' because required module 'libxml' is not loaded



  • Just burned and booted up pfSense-2.0-ALPHA-ALPHA-20090311-0120.iso.gz, and it complained throughout the startup sequence about being unable to load the xml module, due to libxml not being loaded.

    An example error message reads:
    Warning: Cannot load module 'xml' because required module 'libxml' is not loaded
    in Unknown on line 0
    pid 190 (php), uid 0: exited on signal 11 (core dumped)
    Segmentation fault (core dumped)

    Tried installing it to see if it made a difference, but I'm still getting them all over the place, so I can't configure from the console.

    Trying an earlier build to see if it makes a difference, but something's fairly broken there…

    Edit: This wasn't broken in the build taken from pfSense-2.0-ALPHA-ALPHA-20090308-1838.iso.gz - although this has it's own problems!



  • Same with me. After upgrade to that image (2.0 was before but older image) all went down.
    Same message.

    Sasa



  • Known issue that we're working on.  Thanks

    –Bill



  • As an added bonus on embedded, the /etc/php.core fills the root file system when this happens.


Log in to reply