Slow handshake and slow initial loading for youtube using switch



  • Hi! I have a problem with my Pfsense setup and I would like to get some help because this is becoming extremly annoying for me.
    I have a pentium G4400 with 4gb, 120gb ssd, 2 NICs: Realtek RTL8111GR (integrated into the motherboard, also with updated driver 1.95) for WAN and Edimax EN-9260TXE V2 for LAN. I use the LAN port directly to a 48port gigabit switch: Netgear GS748TS (with updated firmware to the latest version) which splits connections across the house.
    The problem is that literally any device connected to it spends about 30 to 90 seconds to connect (it says authenticating in windows). Also, on any device that I try to watch some youtube videos, I get slow initial loading of the video (the video shows that it's loading for about 2 to 15 seconds before it actually starts). I don't have any other problems, the speed is awesome, other sites don't have these specifics problems.
    I would like to add that if I bypass the switch, this slow initial loading of the videos problem nor the slow handshake problems are not present.
    I might not be aware of a certain setting which could fix my problem so I'm asking for your help.


  • LAYER 8 Global Moderator

    @draand28 said in Slow handshake and slow initial loading for youtube using switch:

    I would like to add that if I bypass the switch, this slow initial loading of the videos problem nor the slow handshake problems are not present.

    How exactly are you doing that? So your saying only youtube is a problem? And it only happens when using the switch?

    I would suggest you sniff on your PC when you do this.. Then bypass the switch (how ever your doing that?) and then sniff again..

    Are you using a different switch, are you connecting your PC directly into pfsense interface. How are you bypassing the switch?



  • I have tried to connect a few devices directly to the pfsense machine and the problem does not persist, this is what I mean by "bypassing the switch".
    The problems are that it takes 30 to 90 seconds to get OSes recognize "internet connection" and that youtube videos initial buffer is delayed by 2 to 15 seconds. I have encountered these problems on Linux, Windows and Android (connected usb NIC to my phone).


  • LAYER 8 Global Moderator

    Does the switch show the interface come up (via lights)... What if you wait for your device to be UP, ie showing internet do you then have problems?

    Are you using any sort of 802.1x on the switch? What is the config for the switch ports... Without say Portfast on cisco ports can take a bit to come up.

    I don't have that switch to play with.. You prob have better help with that switch on the netgear site..

    So the question is... If you turn on your PC, and let it sit for say a minute until it shows that it has internet.. Is youtube fast then? If you go to other sites that you say are fast, and all working - and then go back to youtube do you have the problem?

    If your switch is not doing what cisco calls portfast, and its sending out BPDU, and has to wait for spanning tree to converge then yeah it can take a bit for a port to come up, ie go into forwarding mode... With cisco you can set the port so it doesn't do that for end devices like PCs etc..

    Not sure what this really has to do with pfsense?



  • I have asked here about this problem because I thought that there could be some incompatibilities with the switch's default settings and pfsense, or that I might have to modify some pfsense-related settings in order to fully function properly with the switch.
    802.1x configuration:
    Authentication Method on RADIUS,None ;
    Port Based Authentication State Disabled ;
    Guest VLAN disabled.
    Also, the problems are not happening in the same time. Initial buffer in youtube videos is an all-time problem, meaning that it's not just when connecting the device to the switch, videos won't load fast enough even if I keep my PC on for 1 hour.
    The problem with windows and other OSes showing yellow triangle and no internet for 30 to 90 seconds makes the connection impossible to use for that time, meaning that I can't even access pfsense machine's IP or any other sites.
    These 2 problems are not linked in any manner.
    All I want to know is if pfsense affects in any possible way the switch and causes this problem, so I can focus my attention to the switch.

    EDIT: I think I have just fixed it, upon your recommendation, by disabling Spanning Tree State and using BPDU Handling on Flooding. Thank you for the support.


  • LAYER 8 Global Moderator

    So you have a LOOP? I would not turn off spanning true..

    You need to make sure you do not create any loops on your switch..

    I would set the features back to what they were before.. And then disconnect all devices from the switch vs just pfsense and the 1 PC your using... How does it work now? Then start connecting things back to the switch..

    Do you understand what spanning tree does? Do you have any other switches in the network? If you disable spanning tree you need to know for SURE your not creating any loops in your network.



  • I have disconnected all other devices except my PC, after re-enabling those features the problem persists. I should also mention that STP operation mode is in: RSTP (the other unchecked options are STP or MSTP).
    Now, I have tried to disable again STP but use BPDU on Filtering and it works just fine.
    No, I do not have a good understanding of STP as I'm just starting to learn networking.
    I do also have a 2nd cheap residential switch from TP-link with just 4 ports that's connected to the netgear one.
    I don't think I have any loop, at least not an intentional one.


  • LAYER 8 Global Moderator

    @draand28 said in Slow handshake and slow initial loading for youtube using switch:

    I do also have a 2nd cheap residential switch from TP-link with just 4 ports that's connected to the netgear one.

    You only have 1 port from this switch connected to the 48 port switch.. A loop is when you would connect a device that could bridge traffic with more than 1 port.

    Ie a switch for example with more than 1 port.. That does not know how to setup lagg or lacp to allow for that. Any device that might bridge like a desk phone, or any sort of IOT device that is wireless and wired at same time, etc..

    RSTP would be the current normall mode of STP yes.. Its possible the switch firmware has issues with STP? Sorry but I do not have that switch to do any playing with... I would suggest you reach out to their support or forums for what might be going on, and better info in tracking down the actual root of the problem.



  • The small 2nd switch has 5 ports in total, 1 to the netgear one, and the other 4 to different devices. I'm not using Lan Aggregation yet as I do not have enough cables to do so. This 2nd switch does not support any type of management, but in the near future i plan to shut it down (now I'm using it as a wired repetear).
    I understand what bridging does and I'm not trying to achieve that right now. Also, I don't have any bridged connection at the moment.
    I will seek further assistance from netgear itself or netgear community as I've come to learn that this is not a pfsense-related issue.
    I would like to thank you a lot for your time and your assistance.
    Also, I would like to thank pfsense developers for making such an awesome software. The main reason that I've got into networking is because all residential/average user routers use glitchy software, are slow and have low customization possibilities. Pfsense software has great performance, many options, stability and a friendly community.
    Cheers!


  • LAYER 8 Global Moderator

    Wish I could be of more help, but I don't have much experience with that line of switches. If you have corrected your problem by disable STP then your fine as long as you do not create a loop ;)

    If you find out what the root of the issue is with that switch - stop back by and let us know...



  • I will not create a loop any time soon.
    If I will find the solution, be sure that I'll post it here.
    Have a good one!


Log in to reply