[SOLVED][XG1537] CPU-load jumped up, but no culprit to be found



  • Hello!

    I am in the process of configuring a new Netgate XG1537 appliance to replace an old but still trusty core i7 consumer PC as our main firewall.

    Until today all went reasonably well. The CPU-temperature is always above 60°C which is pretty warm for an idle system, but at least the CPU-load was at 0% as expected.

    Today at 9:00 o'clock sharp, when I connected a single client via OpenVPN, the CPU-Load jumped to 6% and stayed there ever since. The load-average is also above 1.00, which as far as I know is in the limiting territory.

    I can not see a process hugging the CPU and frankly, the system has NOTHING to do at the moment. After a clean reboot, the CPU jumped back to 6% usage and above 1.00 load average immediately.

    What is this?
    I have changed NOTHING at 9 o'clock and all in all the system settings are basically the Netgate defaults.
    So far I have just installed a MultiWAN with 5 Connections, 3 OpenVPN Servers and about 20 VLAN Interfaces. Right now, there is NO traffic anywhere.

    Please advise how to find out what is going on.
    Once in productive use, this machine hat to be 100% reliable!
    It cannot afford to do unexplainable things like this!

    Thank you!

    Holger

    0_1548327931483_CPU-load-jump-at-exactly-9-o-clock.png
    2_1548327931483_Nothing-to-do-but-load-average-above-one.png
    3_1548327931483_TOP-shows-nothing-noticeable.png
    1_1548327931483_CPU-temp-constant-but-a-bit-high.png



  • The package/update servers seem to be down at the moment, this causes pkg-static to hang and consume a fair bit of CPU time.



  • Thank you for the fast reply!
    That's it. In fact is was there right in front of me the whole time, but I did not see it:

    [2.4.4-RELEASE][]: top | grep pkg-static
    14264 root           1 103    0 10484K  6160K CPU4    4 116:11 100.00% pkg-static
    
    

    Is there any way to limit access to the update servers?
    Right now, every call of the dashboard initiates an update check.
    Can I set it to manual polling only?



  • @pfimprudence said in [XG1537] CPU-load jumped up, but no culprit to be found:

    Can I set it to manual polling only?

    Yes, look at System -> Update -> Update Settings.


  • LAYER 8 Rebel Alliance



  • Thanks again!
    In the meantime, the problem resolved itself, but it's important to know stuff like that can happen :)