Cant update 2.4.0 to 2.4.4 and find no packages..



  • I have currently version 2.4.0 installed, pfsense still tells me its the latest version and i cant find any packages..
    I have seen alot of threads with similar issues but nothing has solved my problem..

    This is what ive tried (that i can remember)

    changed to latest dev snapshots and then back to stable

    pkg-static update -f
    
    Updating pfSense-core repository catalogue...
    pkg-static: Repository pfSense-core load error: access repo file(/var/db/pkg/repo-pfSense-core.sqlite) failed: No such file or directory
    12664020:error:140940E5:SSL routines:ssl3_read_bytes:ssl handshake failure:/usr/local/poudriere/jails/pfSense_v2_4_4_amd64/usr/src/crypto/openssl/ssl/s3_pkt.c:1216:
    pkg-static: https://pkg.pfsense.org/pfSense_v2_4_4_amd64-core/packagesite...: Operation timed out
    Unable to update repository pfSense-core
    Updating pfSense repository catalogue...
    pkg-static: Repository pfSense load error: access repo file(/var/db/pkg/repo-pfSense.sqlite) failed: No such file or directory
    12664020:error:140940E5:SSL routines:ssl3_read_bytes:ssl handshake failure:/usr/local/poudriere/jails/pfSense_v2_4_4_amd64/usr/src/crypto/openssl/ssl/s3_pkt.c:1216:
    Fetching packagesite.txz: 100%  136 KiB   3.4kB/s    00:41
    Processing entries:   0%
    Newer FreeBSD version for package cpustats:
    To ignore this error set IGNORE_OSVERSION=yes
    - package: 1102000
    - running kernel: 1101001
    Allow missmatch now?[Y/n]: n
    pkg-static: repository pfSense contains packages for wrong OS version: FreeBSD:11:amd64
    Processing entries: 100%
    Unable to update repository pfSense
    Error updating repositories!
    
    pfSense-upgrade -4
    
    >>> Updating repositories metadata...
    Updating pfSense-core repository catalogue...
    pkg-static: Repository pfSense-core load error: access repo file(/var/db/pkg/repo-pfSense-core.sqlite) failed: No such file or directory
    pkg-static: https://pkg.pfsense.org/pfSense_v2_4_4_amd64-core/meta.txz: Operation timed out
    repository pfSense-core has no meta file, using default settings
    pkg-static: https://pkg.pfsense.org/pfSense_v2_4_4_amd64-core/packagesite...: Authentication error
    Unable to update repository pfSense-core
    Updating pfSense repository catalogue...
    pkg-static: Repository pfSense load error: access repo file(/var/db/pkg/repo-pfSense.sqlite) failed: No such file or directory
    pkg-static: https://pkg.pfsense.org/pfSense_v2_4_4_amd64-pfSense_v2_4_4/p...: Operation timed out
    Unable to update repository pfSense
    Error updating repositories!
    
    pkg update -f
    
    Updating pfSense-core repository catalogue...
    pkg: Repository pfSense-core load error: access repo file(/var/db/pkg/repo-pfSense-core.sqlite) failed: No such file or directory
    pkg: https://pkg.pfsense.org/pfSense_v2_4_4_amd64-core/meta.txz: Authentication error
    repository pfSense-core has no meta file, using default settings
    Fetching packagesite.txz: 100%    2 KiB   1.8kB/s    00:01
    Processing entries: 100%
    pfSense-core repository update completed. 7 packages processed.
    Updating pfSense repository catalogue...
    pkg: Repository pfSense load error: access repo file(/var/db/pkg/repo-pfSense.sqlite) failed: No such file or directory
    pkg: https://pkg.pfsense.org/pfSense_v2_4_4_amd64-pfSense_v2_4_4/m...: Operation timed out
    repository pfSense has no meta file, using default settings
    pkg: https://pkg.pfsense.org/pfSense_v2_4_4_amd64-pfSense_v2_4_4/p...: Authentication error
    Unable to update repository pfSense
    Error updating repositories!
    

    /var/db/pkg/repo-pfSense-core.sqlite does not exist no matter what i do.
    dns settings seems fine since i can ping and nslookup sites from the installation.

    Any suggestions?

    edit:

     cat /usr/local/etc/pkg/repos/pfSense.conf
    FreeBSD: { enabled: no }
    
    pfSense-core: {
      url: "pkg+https://pkg.pfsense.org/pfSense_v2_4_4_amd64-core",
      mirror_type: "srv",
      signature_type: "fingerprints",
      fingerprints: "/usr/local/share/pfSense/keys/pkg",
      enabled: yes
    }
    
    pfSense: {
      url: "pkg+https://pkg.pfsense.org/pfSense_v2_4_4_amd64-pfSense_v2_4_4",
      mirror_type: "srv",
      signature_type: "fingerprints",
      fingerprints: "/usr/local/share/pfSense/keys/pkg",
      enabled: yes
    }
    
    pkg-static update -f
    Updating pfSense-core repository catalogue...
    pkg-static: Repository pfSense-core load error: access repo file(/var/db/pkg/repo-pfSense-core.sqlite) failed: No such file or directory
    12664020:error:140940E5:SSL routines:ssl3_read_bytes:ssl handshake failure:/usr/local/poudriere/jails/pfSense_v2_4_4_amd64/usr/src/crypto/openssl/ssl/s3_pkt.c:1216:
    pkg-static: https://pkg.pfsense.org/pfSense_v2_4_4_amd64-core/packagesite.txz: Operation timed out
    Unable to update repository pfSense-core
    Updating pfSense repository catalogue...
    pkg-static: Repository pfSense load error: access repo file(/var/db/pkg/repo-pfSense.sqlite) failed: No such file or directory
    12664020:error:140940E5:SSL routines:ssl3_read_bytes:ssl handshake failure:/usr/local/poudriere/jails/pfSense_v2_4_4_amd64/usr/src/crypto/openssl/ssl/s3_pkt.c:1216:
    Fetching packagesite.txz: 100%  136 KiB   3.4kB/s    00:41
    Processing entries:   0%
    Newer FreeBSD version for package cpustats:
    To ignore this error set IGNORE_OSVERSION=yes
    - package: 1102000
    - running kernel: 1101001
    Allow missmatch now?[Y/n]: n
    pkg-static: repository pfSense contains packages for wrong OS version: FreeBSD:11:amd64
    Processing entries: 100%
    Unable to update repository pfSense
    Error updating repositories!
    




  • same problem for me on all my pfsense servers, all of them resolve srv records fine...
    seems to be a problem
    take a look at the twiter netgate account https://twitter.com/NetgateUSA/status/1088455647807455232


Log in to reply