Multi WAN, interference between connections?



  • Switching from 2.3.5 to 2.4.4 I'w encountered some problem.

    I have two connections to internet
    WAN, a 4G mobile connection via a Dovado Tiny AC router in bridgemode. (IP via DHCP)
    OPT1, standard ADSL connection. (IP via DHCP)
    I have WAN as default gateway.

    Before upgrading everything worked fine. After upgrade, my WAN connection started to go down every ~620 sec.

    After some research I found that it has to do with the DHCP of my OPT1 connection. Why? Every time the OPT1 request a new leas the WAN goes down. this I found out monitoring the connections with ping

    Also, looking at the log the OPT1 makes multiple requests for a ned DHCP leas

    Jan 25 15:09:35	dhclient	31199	DHCPREQUEST on igb2 to 81.227.24.1 port 67
    Jan 25 15:09:36	dhclient	31199	DHCPREQUEST on igb2 to 81.227.24.1 port 67
    Jan 25 15:09:38	dhclient	31199	DHCPREQUEST on igb2 to 81.227.24.1 port 67
    Jan 25 15:09:41	dhclient	31199	DHCPREQUEST on igb2 to 81.227.24.1 port 67
    Jan 25 15:09:45	dhclient	31199	DHCPREQUEST on igb2 to 81.227.24.1 port 67
    Jan 25 15:09:53	dhclient	31199	DHCPREQUEST on igb2 to 81.227.24.1 port 67
    Jan 25 15:09:53	dhclient	31199	DHCPACK from 81.227.24.1
    Jan 25 15:09:53	dhclient		RENEW
    Jan 25 15:09:53	dhclient		Creating resolv.conf
    Jan 25 15:09:53	dhclient	31199	bound to 81.227.63.137 -- renewal in 600 seconds.
    

    The strange thing is, setting OPT1 as default gateway, instead of WAN, eliminates the problem. The WAN connection keeps up and the log looks ok

    Jan 25 15:19:53	dhclient	31199	DHCPREQUEST on igb2 to 81.227.24.1 port 67
    Jan 25 15:19:53	dhclient	31199	DHCPACK from 81.227.24.1
    Jan 25 15:19:53	dhclient		RENEW
    Jan 25 15:19:53	dhclient		Creating resolv.conf
    Jan 25 15:19:53	dhclient	31199	bound to 81.227.63.137 -- renewal in 600 seconds.
    

    This came when upgrading to 2.4.4.

    How is it possible that the OPT1 connection can interfere with the WAN connection?

    Any advice?


  • Netgate Administrator

    In what way does the the WAN 'go down'? What do you see logged?

    Are you running 2.4.4p2? There were some default gateway issues in 2.4.4.

    Steve


Log in to reply