Only 2 out of 3 Interfaces run on 1000baseT the third one is always 100baseTX



  • Hi folks,

    I have a HP core I5 PC with 3 network cards. All three are 1Gb cards but only 2 of them are running on 1Gb, the third is always just 100Mb.
    I did several fresh installations and always after first boot it shows me tow network cards which i usually select as WAN and LAN. When i log into the dashboard both are shown as up and running with 1000baseT. However, when i assign the third network card, which is also a 1Gb card it just runns on 100baseTX instead of 1000baseT as it should.

    The third network card is the exact same model like the one which is running on the LAN interface.
    Even more strange, when i reconfigure the system to use the third as the LAN it is running on 100baseTX althogh before it was on 1000baseT.

    I also have replaced the cards but it's still the same. It looks like it can't or don't want to have more than two cards on 1000baseT.

    Is this a bug or some kind of strange limitation?

    Regards and thanks,
    Markus



  • @om606 what device is that NIC connected to? What does that device show the link at? Have you tried connecting the third NIC to a different device? Also does the NIC have status lights on the NIC itself, if so do the status lights show 100 or 1000mbps link?


  • LAYER 8 Netgate

    Sounds like a LAYER 1 problem.



  • Hi

    All NIC are connected to a Cisco 3650/48Gb Switch. for example, sh run int Gi1/0/29 shows the adapter in 100Mb because the switchport speed is configured to auto. If i force the switchport to 1000baseT on the Cisco 3650 then pfsense disables the port.
    The cables are all brand new quality cat6 cables with at least 600Mhz or even higher. I have even replaced all the cables but nothing changed.

    Few days ago i have setup pfsense fresh and before this one adapter was configured as LAN nic and then it was running on 1000baseT but then the OPT1 Adapter was on 100baseTX which is now on 1000baseT.

    This is so strange, it seems like it does not want to have more than two adapters on 1000baseT. Can't this be a licensing limitation or probably a limitation because it would not be able to forward enough data with 3 nic in 1000baseT?

    Thanks,
    Markus


  • Rebel Alliance Developer Netgate

    Either a physical issue or maybe running out of mbufs. Plenty of info on how to fix that in the docs, if that's the case.



  • I personally would say that the ethernet cable needs checking, or replace it. This is the common reason why 1gbps NICS go down to negotatiate at 100 mbps.

    Some ethernet cables don't support 1gbps (If all of the strands in the cable are not available). If it is a custom crimped cable then it would probably need re-crimping / checking.



  • There are several things to look at:

    1. Verify what your interfaces are set at. Should be auto unless your switchports are hard set:

    0_1548638014838_2019-01-27 19_12_27-.png

    1. From the PFsense shell, post the ifconfig results from the interface you're having issues with (e.g. ifconfig em1)

    2. If you haven't already, replace your cables with prefabbed CAT6

    3. Assuming the interface in question is patched into G1/0/29 on your 3560, post the results of "sh run int g1/0/29"

    4. Post the results of "sh int G1/0/29"

    5. Post the results of "sh int status"

    6. Run a TDR test on G1/0/29 and post the results.

    There's going to be a lot of text, so I would definitely code your results when you post.


  • Netgate Administrator

    Does it do the same on different switch ports? It could be a bad port.

    It's not any sort of limitation in pfSense. All Gigabit NICs should link at 1Gbps regardless of whether or not the hardware can make full use of that.

    Steve


Log in to reply